Qt Creator not working

Hi, I have been trying to install Qt Creator but it does not build or run oF projects. When creating a new project, the ‘src’ folder does not show up. The addons folder is also not there.

At the top, Qt Creator gives me this warning:

this file is not part of the project. The code model might have issues parsing this file properly.

I just created a new project but it shows this above warning.
When I try to build and run, I get this error:

You need to set an executable in the custom run configuration.

Does anyone know what this means ? How can Qt Creator work correctly ?
I’m on Ubuntu 22.04

Thank you

Hi Will :slight_smile:

Which version of QtCreator? I’m using 7.0.1 on Ubuntu 21.04.

Hi Abe, I’m using 7.0.1 on Ubuntu 22.04

Hi and sorry if these are obvious questions, but have you followed all the steps on
especially running the script mentioned in the last sentence in the Linux section?

I use QT Creator 7.0.0 on Debian 11 Testing and it works quite good.

Yes, I have.
It is why I am puzzled…

And did you try clicking the wrench icon on the left? I think it’s the fourth icon. Sometimes there it was asking to “configure the project”. Also check the qbs file if you see anything suspicious.

Maybe I could take a look during the weekend (if it’s a laptop and you have time to meet). Cheers!

1 Like

@WillpowerStudios, when you create a new project, do you have the openFrameworks options?

Hi, yes, I have the openFrameworks options. It is once the project is created that issues arise…

Hmmm…you say this happens when you create a new project. Can you open any examples project?

If not, I’d reinstall.

I have… I’m planning on installing older versions to see if it fixes it. The oF site suggests 4.6.1

This is what happens when opening a project

I ran 4.6 for a while, but updated to 7.0, which works well, too.

One thing to try that I do when QT Creator messes up, like it does when for example adding files to an addon:

Close the project.

Delete the .qbs.use file and all builds.

Open the project, Configure it (to Desktop in my cases).

Does this work for you?

Hi Staffan,
Thank you for your suggestions.
It is not working for me… I’m still trying to understand why when using the openFrameworks option to create a new project, it does not show the src and bin folders… I wonder what it could be…

@WillpowerStudios sorry I can’t help you any further… One last idea. Try to run QT Creator from the command line, look for any errors that indicate something is missing.

Thanks Staffan. I opened qtcreator from the terminal, it opens fine, no errors, but unfortunately, the issue remains… the only file showing is the .qbs file of the project without the other files and folders… I’m so stuck and not able to do my work which is very challenging… Thank you so much for your suggestions, I really appreciate it !

I am getting frustrated because I don’t know how to help you! :slight_smile:

Can you open the examples?

Do you have another computer/installation which you could try on?

Can you go to an example folder and compile the project from there?

Thank you so much Staffan ! I deeply appreciate it.
Yes, I can open the examples, build and run them from the terminal!
But not in QT, as it does not load the entire folder…

I do not have another computer but it was running fine in ubuntu 21… it hasn’t worked every since I installed 22…
I wonder why…

I’m still trying and thinking of solutions but I haven’t found one yet…
At worst, I will work directly from the folder but it would be nicer to have a good IDE…
Do you know another good IDE for working with oF on linux ?
I’m thinking of atom or visual studio.
I saw a couple of posts in the forum about it…

Sorry no… I’ve only used QT Creator. And I am pretty new to oF.

Someone more experienced than me will have to help here…

Hmm, just saw this. In a terminal:


then start QT Creator from the same terminal.

It should tell you if any plugins fail to load! (Source: I can't open qtcreator in ubuntu | Qt Forum)

Ok, a friend of mine helped me and got it working by installing the gtk±3.0 package