Provisioning profile

Hi.

Now I am working in openframeworks on iPhone 3GS. When I try to install my openframeworks App on iPhone, I get such message,

“This provisioning profile does not have a valid signature ( or it has a valid, but
untrusted signature)”

I know I have to rewrite Developer Profile in Code Signing and Bundle Identifier in info.plist.
Actually, I succeeded to install normal view-based App on iPhone, but I could not do same thing when I tried to use openframeworks on iPhone.

Could anybody help me ?

try making sure you change the code signing identity in both the target build settings and the project build settings (when you double click on the xcode project at the top of the files list on the left side of the window.

sometimes that helps. also make sure when you change them, you change them for ALL of the configurations, not just the active one, im not sure why this makes a difference, but it solved the same error for me. (set the configuration for All Configurations, and then change the code signing identity… obviously if you want to compile for distribution you’ll have to go back in and change the profile later)

does it work after those changes?

Hi, thank you for answering my question !

All configuration means Debug, Release, and Distribution ?
I just tried to change their code signing in Project and Target,
but it did not solve the problem…

I’m having the same problem. New to openFrameworks, but not to iPhone programming. It’s a little frustrating, because solutions that work on regular iPhone projects don’t with openFrameworks.

All I can suggest is to build the iPHone project from scratch, which is time consuming if this is your first time working with something like openFrameworks.

One suggestion that I can make to the openFrameworks people is to create a blank iPhone project (not a template to drop into xcode) with generic provisioning profiles and all the necessary OF files included. Keep the bundle identifier in your pList generic.

One more suggestion, don’t name the sample projects with a space. Makes it difficult to add to iPhone for testing purposes. You always want to test on your iPhone/iPod Touch.

So instead of “oF Iphone” name your samples “oFiPhone”. This can save you tremendous time when wanting to submit to the iTunes.

Demetrius

Hi - yes as suggested make sure Project Settings and Target Settings show the same info for the profile. To get target settings right click on the Targets->AppName (in the side bar) and select Get Info.

Another way to check is to right click on the xcode project in the Finder and do “Show package contents” then open project.pbxproj in a text editor. Search for the text “MSA Visuals Ltd” if you see it then you have missed somewhere where your name should be instead.

Basically you shouldn’t see:
iPhone Developer: Mehmet Akten
or
iPhone Distribution: MSA Visuals Ltd

Also another important thing is that you can’t rename your app without getting a new signing profile for it. So if you get a profile for myBallsProject and then later you duplicate the project and rename it you will get an error that the profile is not valid. This could be what you are experiencing.

Also this might be useful - http://memo.tv/xcode-templates-for-open-…-and-iphone

theo

Hey,

the provisioning thing usually is a bit of a nightmare, but once you get the hang of it, it’s not that bad. The openframeworks xcode project is a normal iphone xcode project (with a bunch of .cpp’s already added to it) so any rules that apply to normal iphone xcode projects still apply.

You need to make only 2 changes to the xcode project (mentioned at the bottom of http://www.memo.tv/ofxiphone )

  1. say who the developer is (set your developer profile in the project build settings)
  2. say who the app is (set your bundle identifier in the info.plist)

or with more detailed info :

  1. select your Developer Profile in Project Settings >> Build > Code Signing. You need to do this for the Release target and Debug target. This should be something like
    iPhone Developer: John Doe

  2. set the Bundle Identifier in info.plist to whatever you created your Developer Profile with. e.g. com.yourcompany.* This can sometimes be confusing as people don’t remember what they put. If you don’t remember goto
    http://developer.apple.com/iphone/manag-…-dex.action
    and look at what you have. it should be a weird string followed by some stuff in the format of
    HGHKJ53GH.com.yourcompany.*
    you need to put that string in (minus the first string) so com.yourcompany.*

Very important and what most people forget, is you need to clean and rebuild all after making any such modifications.

If it still doesn’t work, then you probably haven’t installed the developer profile correctly :confused:

good luck!

P.S. Theo you don’t need a new signing profile for each app if you create it with a wildcard, e.g
com.yourcompany.*

Oh - thanks Memo!
Thats great to know.

I kept having to overwrite my old app or ask for a new profile :smiley: