projectGenerator is not work with libboost-1.72.0

OS : Linux 4.19.107-1-MANJARO #1 SMP Fri Feb 28 21:14:27 UTC 2020 x86_64 GNU/Linux (arch linux)

recently I found that projectGenerator is not working due to libboost-1.71.0 shared library missing. so I downgrade from libboost-1.72.0 to libboost-1.71.0.

but now libreoffice is not working due to lack of libboost-1.72.0.
is there any solution that oF working with boost-1.72.0? I tried runinstall_dependencies.sh, with oF script.

recompiling projectGenerator, (after downgrading make version 4.2.1, not 4.3.) can resolve issue.