Project generator freezes

Hi forum,

I have just managed to install of and having trouble with the project generator. As a try out, i managed to use the project generator as well. Later when i want to use the generator again to create another project with some specific addons,
the project generator freezes. I have to force to exit the generator as follows:

/////////////////////////////////////////////
Addons:
GENERATE PROJECT
<< BACK
[verbose] ofx3DModelLoader
[verbose] ofxNetwork
[verbose] ofxOpenCv
[verbose] ofxSvg
[verbose] ofxThreadedImageLoader
[verbose] obj
[verbose] ofxAssimpModelLoader
[verbose] ofxXmlSettings
[verbose] ofxVectorGraphics
[verbose] ofxGui
[verbose] ofxOsc
[verbose] ofxKinect
[verbose] listed 12 files in “/home/sajjad/Downloads/openFrameworks/release/of_v0.8.1_linux_release/addons/”
Platforms: linux (codeblocks)

exit
^C[verbose] ofAppRunner: sighandler caught: 2
[verbose] ofEvents: OF app is being terminated!

////////////////////////////////////////////

Any hint to get rid of it ?

Thanks

What distribution of Linux are you using? So you included those 11 addons?

hi

I am using ubuntu 12.04 on Intel i7 and Nvidia gtx560m graphics board.

I did manage to include the addons now running from projectGnereationSimple

I just included two addons required to serve my purpose .

Now the project generator is crashing with the following message:

//////////////////////////////////////////////////////////////
sajjad@sajjad-G74Sx:~/Downloads/openFrameworks/release/of_v0.8.1_linux_release/projectGenerator$ Name: mySketch
Path: /home/sajjad/Downloads/openFrameworks/release/of_v0.8.1_linux_release/apps/myApps
Platforms:
Addons:
GENERATE PROJECT
<< BACK
[verbose] ofx3DModelLoader
[verbose] ofxNetwork
[verbose] ofxOpenCv
[verbose] ofxSvg
[verbose] ofxThreadedImageLoader
[verbose] obj
[verbose] ofxAssimpModelLoader
[verbose] ofxXmlSettings
[verbose] ofxVectorGraphics
[verbose] ofxGui
[verbose] ofxOsc
[verbose] ofxKinect
[verbose] listed 12 files in “/home/sajjad/Downloads/openFrameworks/release/of_v0.8.1_linux_release/addons/”
Platforms: linux (codeblocks)
[xcb] Unknown sequence number while processing queue
[xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
[xcb] Aborting, sorry about that.
projectGenerator: …/…/src/xcb_io.c:274: poll_for_event: Assertion `!xcb_xlib_threads_sequence_lost’ failed.
[verbose] ofAppRunner: sighandler caught: 6
[verbose] ofEvents: OF app is being terminated!
projectGenerator: Fatal IO error 2 (No such file or directory) on X server :0.

/////////////////////////////////////////////////////////////

@zach @arturo could you take a look at this?

are you running in a virtual machine? and if not do you have the nvidia drivers installed?

No , i have the nvidia drivers installed and functional

can you try editing this lines in main.cpp in the projectGeneratorSimple project:

    ofAppGlutWindow window;
    ofSetupOpenGL(&window, 1024, 610, OF_WINDOW);

and changing them to:

    ofSetupOpenGL(1024, 610, OF_WINDOW);

and recompiling it

1 Like

Thanks for the hint!

Let me clear it first …

Are projectGenerator and projectGeneratorSimple different ?

I changed as you suggested and projectGeneratorSimple was fine from the very beginning and the suggested amendments did not alter its behavior.

But projectGenerator is very bumpy. Some times it works and sometimes it does not. The whole system freezes

So as of right now i am creating new project with the projectGeneratorSimple.

Thanks

projectGeneratorSimple is the user facing PG, projectGenerator is the developer version. we plan on merging both of them into one PG.

I have the exact same issue running Ubuntu 13.10 x64 with Nvidia drivers installed. Both PGs are actually quite unstable for me. I thought it might be cause OF is compiling against GTK+2.0 and not 3.0 which I changed in the common Linux make file but this had no effect. It either freezes or crashes with

(projectGeneratorSimple:28321): Gdk-WARNING **: projectGeneratorSimple: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.

Arturo’s suggestion worked for PGSimple.

I just installed on Ubuntu 14.04 64-bit and ran into the same problem with projectGeneratorSimple. Arturo’s suggestion worked for me.

@arturo would you mind pushing that fix to the repo?