Project Generator Compilation Issue

#1

Just tried to compile the Project Generator in 0.10.1 and I can’t get it to finish. I’ve already compiled the dependencies and codecs under sudo successfully. This is being compiled on Ubuntu (Kubuntu) 18.04 64bit. The full traceback is here. Hopefully someone can figure this out. It seems to be rooted in the ofVideoPlayer.cpp file.

EDIT:
This error also occurs when attempting to sudo ./compileOF.sh as well.

#2

You’re implying you’re working in Linux (Ubuntu). If only I could help you… Just installed Linux Mint on one of my computers, and wonder how well does the OpenFrameworks work with it; whether there are many issues writing a program in it and compiling it or not…

I guess you should change the topic of the post to linux though, because this is pretty much linux-oriented issue…

#3

I think it was a result of the really unclear documentation oF has. I ended up just using the command line project generator which worked properly. Right now I’m just fighting with CMake to get the project to build.

#4

Your trace back seems GLEW issue, which is quite recent one. As Arturo mentioned time to time in this forum, you can use nightly build in the maen time.

If you want to compile frontend PG, check out this page. https://github.com/openframeworks/projectGenerator/blob/master/frontend/readme.md