Program crashing when opening Soundstream

Using the nightly build (20200207) gcc6 on Arch Linux I tried to start the Audio Output example.

It crashed when trying to open a SoundStream:

ofRtAudioStream.cpp

Line 180: audio->openStream(

Someone could help?

Here’s seems fine (ubuntu 18.04.4, OF 0.11 stable).
Have you tried with the version you can download from OF site, avoiding the nightly build?
If the problem persist, maybe post exactly the error you get…

I compiled it with the stable version as well. Still the same error. More specifically it crashes when starting a thread (method called start_thread) with this error:

The inferior stopped because it received a signal from the operating system.

Signal name : SIG32
Signal meaning : Real-time event 32

For me this unfortunately not seems very helpful.

Sorry, no clue for the error you’re encountering… just some thoughts:

  • tested with OF11 on fedora 29, compiles and run fine
  • archLinux seems a little bit too bleeding edge. I’ve tested some time ago (on Raspberry Pi), and found some problem with library version unsupported, as they are too new. Maybe you’ll have better luck switching to another distro, more suitable for development (or maybe you can try asking in dedicated distro forum)