Process launch failed for sample project


I am running apps on Ipad mini 2 without an Apple License. I followed this tutorial: and it works for projects I create from scratch, but when I try to load one of the sample OF projects, it does not work and gives me a “process launch failed” error. I have tried all the suggestions I found on SO regarding provisioning profiles, but nothing has worked. I suspect it has to do with precompiled headers.

Things I have already tried:
Clean project
provisioning profile changes:
Delete derives data

Note: It works perfect for projects made from scratch


any help, please?!

Interesting that you are able to get projects that you built from scratch running. Is anyone successfully developing for iOS with openFrameworks 0.8.4 ?

Please let me know if you figure this out!

I’m developing for iOS with oF 0.8.4
I’ve never tried installing to a jailbroken device though.
2 things

  • can you compile and run on the simulator?
  • are there any other error messages you get?

No, I can’t run on the simulator. Its always been a pain to run OF projects on the simulator since you need to use different precompiled headers depending on whether you use a device or the simulator since both compile for different instruction sets.

Other times I get “cannot start process ######…”


strange it runs of when coding it from scratch but not otherwise.

I ran into same problems lately and did some research. I combined some tricks and can now manage to make it to work (my apps and example apps).

I think your problem is related to code signing. i suggest you self code sign your app before sending it using “codesign” command under mac.

I didn’t dig too far, so maybe my solution is a bit messy but it works for now.

Here you can have some clues : [SOLVED] Build app for iOS 5.1.1 AND without Apple Developer account !?

hope this helps