Problems with OpenCV being included

Hi everyone,
I am having problems including OpenCv. The same app runs fine on my old computer, but I have a new computer and it is not finding OpenCV. I have everything in the same place file wise in the addons. I have built the project in the project generator, and I have looked at the file path and it seems to be there but I still am getting errors that things are not found. It is exactly in the same place as before, just on a different mac. It worked on Xcode 11 and Mojave. It does not work on Xcode 12.2 and Catalina. I am confused.

Screenshot 2021-03-24 at 21.07.28.png
Screenshot 2021-03-24 at 21.14.01.png


Can you try running the openCV example from: and see if you get those errors?

It could be your old project was made based on 0.11.0 which had a single opencv.a library file. 0.11.1 and 0.11.2 doesn’t join the libs together into a single opencv.a because it was causing name clashes and basically breaking part of the linked code.

So all that to say you will probably need to use the projectGenerator in 0.11.2 to update your project with ofxOpenCV instead of copying the project over from an older OF release.

I hope that helps!

Hi there, I think I may have experienced the same problem but via an update of Ubuntu; I found typing sudo ln -s /usr/include/opencv4/opencv2/ /usr/include/opencv2 into your terminal fixed it for me. I think it’s basically telling include directives to treat /usr/include/opencv2 calls as calls to /usr/include/opencv4/opencv2/?

Hope it helps :slight_smile: