Problems with installing OF with QtCreator

So, I am just trying to get OpenFramework to work with QtCreator.
(Because VisualStudio requires you to create an account … :angry: )

I am using Windows 10 64bit.
I have installed msys2 and QtCreator (the recommended version).

I am following this tutorial: https://openframeworks.cc/setup/msys2/

I am currently “stuck” on the following part of that tutorial:

Open an MINGW32 shell ( C:\msys64\mingw32.exe ) and install OF dependencies:

cd your_oF_directory/scripts/msys2
./install_dependencies.sh
//That worked fine for me

next, compile oF libraries:

cd your_oF_directory/libs/openFrameworksCompiled/project
make

When I cd into the directory that I unzipped oF into and type in the following:
$ make Makefile
I get this:
make: *** No rule to make target ‘Makefile’. Stop.

I am using the 64 bit “version” of the msys2 shell thing.
This is the first time I am using “make” or anything like it, so I really have no idea …

Any help would be appreciated …

You need to cd to your_oF_directory/libs/openFrameworksCompiled/project not the directory you unzipped OF into.

Then it should work.

Hope that it works for you!
Theo

1 Like

What is the difference between the two?
I have unzipped the downloaded stuff into a folder called “of_v0.11.0_msys264_release” directly in the C drive.
And then I cd’ed into there, into the specified folder.

Where shold I put the OF files instead?

Any help on this would be really appreciated, because the “official” installation tutorial isn’t quite clear about how to do this / where exactly to put the downloaded and unzipped oF folder.

And I would really like to get oF to work …

Hi,

Can you post some screenshots of the window showing where you have cd’d to.
Also can you post a screenshot of either the DIR command or ls -la when you are in the folder you are typing make at.

Your earlier message made it seem you were typing make at the level that libs/ addons/ examples/ etc are when you need to be typing it at this folder level:

The more info you can share, the easier it will be to help :slight_smile:

All the best,
Theo

When I try to cd into C:, that does not work now for some reason.
When I try to go “back” as far as I can with “cd …” and then enter “dir”, I get this:

MyUsernmel@MyPcName MSYS /
$ dir
InstallationLog.txt    etc                  mingw32.ico  msys2_shell.cmd
autorebase.bat         home                 mingw32.ini  network.xml
autorebasebase1st.bat  installer.dat        mingw64      opt
bin                    installerResources   mingw64.exe  proc
clang32                maintenancetool.dat  mingw64.ico  tmp
clang64                maintenancetool.exe  mingw64.ini  usr
components.xml         maintenancetool.ini  msys2.exe    var
dev                    mingw32              msys2.ico
dir                    mingw32.exe          msys2.ini

I edited the username and PC-name for obvious reasons …

So, should I try to find that folder and place the oF files there?
This seems to be the “root folder” of MSYS2, or something like that …
(Don’t know if that is the correct word for that)

Hi,

I just tried on a PC.
I did

cd C: 
cd Users/Username/Downloads/of_v20210222_msys2_mingw64_release/scripts/msys2/

did the install dependencies step

Then

cd ../
cd ../
cd libs/openFrameworksCompiled/project/
make 

If you are going straight from a new shell and you have the download unzipped in C:
You can do:

cd C: 
cd of_v0.11.0_msys264_release/libs/openFrameworksCompiled/project/
make 

If you are still running into issues and are not super familiar with navigating via shell etc, I think it might be worth using the VS download and dealing with the MS account annoyance ( I did the sign in once and have never had any hassle since ).

I hope this helps.
Theo

1 Like

Thanks!
Yes, I think it might be better for everybody involved if I just used the VS version …
But thanks anyway for your valuable time and for trying to help me!

(Yes, I am not really used to working via command line …)