Problems with FreeImage-

I had a major Missing SDK issue at first - so if anyone else has problems when they’ve previously built and trialled on device, you need to head to Targets in the left hand navigation bar in xcode, then double click on your app name to open. You get a window entitled ‘Target Info’, and if you click on the second (Build) tab, you get the last destination of your app, which may now be throwing the Missing SDK error. If you change this, the options for build/release return.

On a separate issue relating to changes in xcode/iphone/openFrameworks, my apps are now throwing the following sorts of errors (some of them, anyway). I followed the advice of the previous post about rebuilding FreeImage with Makefile. I still get errors about typedef int32_t having previous declaration, seems to be from a variety of the linked libraries… any ideas what I might be doing wrong?


/Users/will/Desktop/of_preRelease_v0061_iPhone_FAT-pre3/_apps/iPhoneAddonsExamples/Sobras1/../../../libs/FreeImage/include/FreeImage.h:157:0 /Users/will/Desktop/of_preRelease_v0061_iPhone_FAT-pre3/_apps/iPhoneAddonsExamples/Sobras1/../../../libs/FreeImage/include/FreeImage.h:157: error: conflicting declaration 'typedef int32_t BOOL'  


I got that error first when trying to follow the fix here:±iphone-sdk-4-beta-works-with-ofxiphone/3658/0

I did this…

…but got that error, so I tried this…

[quote author=“jefftimesten”]

  1. Download and expand Freeimage
  2. Download this-Makefile and put it into the FreeImage directory
  3. Run the makefile with make -f Makefile.iphone
  4. Replace the the libraries in /libs/FreeImage/lib/iphone with libfreeimage-iphone.a and libfreeimage-iphonesimulator.a
  5. Add the libraries to your project in the FreeImage group[/quote]

…and then it worked fine.

Thanks Gwydion
I did try that last night but seems not to have made a difference. Did you also perform the hack further up that thread where someone copied files from the standard mac openframeworks and renamed?
One thing I noticed in the FreeImage group is that libFreeImage_iPhone_universal.a is red, ie not added to the project. Is this the same for you on your working version?
Cheers for your help

Yes, I tried that other hack, but that didn’t work for me (different set of errors).

With the lib in red… I dunno, when I added the two lib files to the XCode project they were black and it built everything ok. Today when I opened the same project, those two lib files are in red, and it still builds ok…

I did a “Get Info” on the red libs and it looked like the path was corrupted (probably from multiple users sharing the same .xcodeproj file). So fixed the path, did a clean all -> build and everything’s back in black and still working…

Maybe stupid question, but are you doing a “clean all” before each attempt?

Hi, yes, have been cleaning between builds…
I’m just a bit mystified as to the source of these errors. Going to try and run through the steps with the FreeImage distro and makefile one more time, in case I made a mistake. Also keeping my fingers crossed that a shiny OS4.0 oF package might land from the oF core team superstars :slight_smile:
thanks again for help