problems building examples for device, 'bits' directiory...

Hello everyone,

I’m new to ofx, although I am really excited to see that it is being ported to iPhone. I come entirely from the standard iPhone uikit side of the house so maybe that is why I’m having problems getting started. I’ve been able to run all the demos in the simulator, but when I go to build for the device I’m getting tons of errors… mostly relating to this:

#include <bits/c++config.h>

see image here: http://bayimg.com/gaKlmAAcm

Anyone have any ideas? Using ofx iphone 006, mac os 10.6.2, XCode 3.2.2. Also, when I load up an example/template, the frameworks are colored red, indicating that they can’t be found, but I went ahead and manually added them to the project… but I can’t imagine thats a good sign.

I’m really excited to start working with ofx as my graphics programming skills are limited and this looks like a great step up from processing, but I’m really stumped on this one :confused:

Thanks!

are you using 006 (from the downloads folder) or the github version (0061/0062)? that doesn’t look like 006… It looks like you are using the “compiled lib” version of OF introduced in 0.061. what frameworks are red? something looks wrong w/ your setup…

take care,
zach

Possibly fixed it… changed GCC 4.2 to GCC 4.0 and now I get tons of warnings and a random codesign error so I’m not out of the woods yet. I guess this is some combination of snow leopard + the pre-release XCode that cause the problems.

Anyway, if anyone else is having ‘bits’ problems, make sure to use GCC 4.0 with iPhone ofx 006!

Had the same problems…you’re most likely using the 3.2 beta sdk…its not working right with ofxIphone. Solution for me was to uninstall it all and reinstall the 3.1.3 SDK, then everything worked like a charm.

Here is an awesome link that shows how to delete all of XCode/SDK with one line in terminal

http://macdevelopertips.com/xcode/how-t-…-xcode.html

so awesome, I think undocumented feature of OS X.