problem with opencv installation

but I am trouble installing the opencv addon. I tried to follow the brief installation notes in steps.txt, then created a new project, copied the example src folder into it and tried to build and run. first I got this error:

/Users/marius/OF004/app/cv_test2/openFrameworks/ofMain.h:10:58: error: …/…/addons/ofAddons.h: No such file or directory

and after fixing that I got another error:

Building target “openFrameworks” of project “openFrameworks” with configuration “Release” — (1 error)
duplicate symbol mouse_cb(int, int, int, int)in /Users/marius/OF004/app/cv_test2/build/ and /Users/marius/OF004/app/cv_test2/build/

not sure what this means. anyone can help me with this?

I forgot to mention that I am using Xcode and OF004. and with another example (blobtracking from stefan) I get the same error…

I think you might have made some mistake in how you set up your project.

a) does just straight 0.04 work ?

b) can you try starting again from scratch – and follow the steps in the opencv addon step by step

it looks like you may have included in your project parts of OF twice, or done some thing else wrong, but it’s hard to see it. in the worst case, you can zip the whole folder (apps and libs, etc) and put it online…

take care,

yes, you were right. I tested with 003 and it was working, so I restarted with 004 from scratch and now it’s working. I think I copied stuff twice, first time to a wrong location…

one more thing,
the upper 4 images in the example patch that comes with opencv stay white. I only see the outline at the bottom frame. as soon as I start the app the 4 rectangles turn white. tried to adjust settings, but no difference… (I use the built in iSight.) any idea?

see the top post in the forum -> extend thread±,-readme-/329/0