Problem with install_dependencies in Fedora 15

I am new in OpenFrameworks and Fedora.
I have download OF v0.07 and run, everything ok (I can open Code Blocks IDE).
But when i run instal_dependencies, and error occur.

compiling object for  ../../../openFrameworks/sound/ofSoundPlayer.cpp  
mkdir -p obj/Debug/openFrameworks/sound  
g++ -g3 -Wall -fexceptions -I../../../assimp/include -I../../../assimp/include/Compiler -I../../../cairo/include -I../../../cairo/include/pixman-1 -I../../../cairo/include/cairo -I../../../cairo/include/libpng15 -I../../../fmodex/include -I../../../FreeImage/include -I../../../freetype/include -I../../../freetype/include/freetype2 -I../../../freetype/include/freetype2/freetype -I../../../freetype/include/freetype2/freetype/config -I../../../freetype/include/freetype2/freetype/internal -I../../../freetype/include/freetype2/freetype/internal/services -I../../../glew/include -I../../../glew/include/GL -I../../../kiss/include -I../../../portaudio/include -I../../../rtAudio/include -I../../../tess2/include -I../../../poco/include -I../../../glu/include -I../../../openFrameworks/ -I../../../openFrameworks/video -I../../../openFrameworks/graphics -I../../../openFrameworks/sound -I../../../openFrameworks/math -I../../../openFrameworks/types -I../../../openFrameworks/app -I../../../openFrameworks/utils -I../../../openFrameworks/gl -I../../../openFrameworks/communication -I../../../openFrameworks/events -I../../../openFrameworks/3d -pthread -I/usr/include/gstreamer-0.10 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libxml2   -pthread -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12   -DOF_USING_GTK  -MMD -MP -MFobj/Debug/openFrameworks/sound/ofSoundPlayer.d -MTobj/Debug/openFrameworks/sound/ofSoundPlayer.d -o obj/Debug/openFrameworks/sound/ofSoundPlayer.o -c ../../../openFrameworks/sound/ofSoundPlayer.cpp  
In file included from ../../../openFrameworks/sound/ofSoundPlayer.h:32:0,  
                 from ../../../openFrameworks/sound/ofSoundPlayer.cpp:1:  
../../../openFrameworks/sound/ofOpenALSoundPlayer.h:14:19: error fatal: AL/al.h: No existe el fichero o el directorio  
compilación terminada.  
make: *** [obj/Debug/openFrameworks/sound/ofSoundPlayer.o] Error 1  
there has been a problem compiling Debug OF library  
please report this problem in the forums  

¨No existe el fichero o el directorio¨ means Folder does not exists

When I try to build a project example from OF in Code Blocks, i get an error relate to OpenAL, in the line include <AL/al.h>

I have install OpenAL, but the errors in install_dependencies and build projects in CB persists.

How can I resolve this problem?

the scripts for fedora are probably a little outdated, first of all you’ll need codeblocks 10.05 instead of 8.02

then to install openal and any other packages that are missing in the install_dependencies script you’ll need to install the -devel versions of the packages since that’s the ones that have the headers.

please post the steps if you can solve it so i can update the scripts

will check this soon

I finally get OF work in Fedora 15. I was a little hard, because have few experience in Linux.
I took Ubuntu install_dependencies as an example. I install almost all libraries that are on that file, I could not find some of them for Fedora. I installed: libsndfile-devel, gstreamermm-devel (I also install all of gstreamer libraries, but not sure if its necessary),alsa-lib-devel (Fedora’s version of libasound2-dev), freeglut freeglut-devel (Fedora’s version of freeglut3-dev), libopenal-devel, openal-soft-devel, gcc (instead of g++), freeimage-devel (instead of libfreeimage-dev), gtk±devel (libgtk2.0-dev
), flac-devel, glew-devel.
Another thing I had to do was to move some libraries’ folder to OF libs folder (libs/openframeworks) gst, libxml.
The last thing to get every thing working is to add -lz -lGLU in USER_LIBS in config.make.
Then I was able to test all examples applications in OF.
I hope this help if somebody get the same error, or to update install_dependencies for Fedora.

Sorry, I forgot to answer. I updated the scripts and sent a pull request ob github.