Problem with icons OSX

Hey guys

I’m working on a project, my setup is with vscode, but also tried it with xcode 13 and can’t seem to work this out

How to set the Mac App icon in OF ?

it’s even a bigger problem, because the app compile but it has the "missing icon " icon ( not even the of/of debug one )

tried changing the Project.xcconfig without success at all

please check that the icon file got copied into the app bundle.
In Finder, right-click on the compiled app and select show “Show Package Contents”, a window will pop up, in it go into Contents/Resources. The icon file should be there. If it is not then something went wrong in the icon copying step, which is a “run script” phase in the xcode build phases. double check the relative routes.
Does the missing icon appear only on this project you are working on or is it a general problem?

hei man, thanks for taking the time to help me

This is a general problem that happens in all my apps, tried to copy the
file like u said and still no go! :confused: all my apps are like this, without icons

Which macos, xcode and openFrameworks versions are you using?

Xcode: 13.0
Mac OS : 11.5.1
Openframeworks : 0.11.2

But I don’t use the xcode environment, I use vscode template
to do it, maybe that’s the problem, something is broken there?

Oh, it might be. I dont use vscode, so I cant tell. Why dont you try to compile one of the examples with Xcode and see if the icons show up.

you are right, on xcode everything is fine, this is a problem with the vscode template

thanks dude, lets see how I can fix this

1 Like