problem with codeblocks version of OF to run

I have installed O.F. v0.74 on Codeblocks 10.05 on Win 7 64 to Program Files(x86) and have yet to get any of the example projects to run. I put the the files labeled add_to_codeblocks_mingw_include into MinGW/include. I also put the files from add_to_codeblocks_mingw_lib into MinGw/lib. The folder containing all the example files and the rest are on my desktop.

As the instructions stated, to start it all off I first opened the ImageSaverExample workspace file and compiled the entire openFrameworksLib. Everything appears fine in the Build log. After this step I closed the project out and then opened the ImageSaverExample project file, selected the main.cpp and through codeblocks ran the program. The program appears to launch but then almost instantly I get an error message from my operating system that says “imageSaverExamaple.exe has stopped working”. I also went to the bin folder and double clicked imageSaverExamaple.exe and got the same result. Is there something I can do to get this to work?

0.7.4 does not work with C::B 10.05 any more. get the current version (12.11?), and try again please. :slight_smile:

That was the problem. It works now. Thank you for your reply.

Can I suggest that the code::blocks tutorial hyperlink is changed to go straight to the download page for version 12.11? It will save people from getting confused.

Thanks!

sure you can! please open an issue here: https://github.com/openframeworks/ofSite/issues - this is the bug tracker for the of.cc site (which contains the tutorial), this makes it much easier for us to track those requests.

I have oF v.0.7.4 and Code::Blocks v.12.11 on Windows XP. It successfully built examples …\math\trigonometricMotionExample and …\graphics\Color. But every attempt to run them ends
with “Process returned -1073741819 (0xC0000005) …” in the command prompt screen and “Process terminated with status -1073741819 …” in the “Build log” tab of CodeBloks output (“Logs & others”). Any suggestions?

having this problem this morning with openni example. Codeblocks keeps freezing and saying that the program has stopped working this is the only instance that I have encountered.

  
Checking for existence: C:\Users\Ciaran\Desktop\of_v0.7.4_win_cb_release\apps\examples\opeNI-SimpleExamples\bin\openNISample007.exe  
Executing: "C:\Users\Ciaran\Desktop\CodeBlocks/cb_console_runner.exe" "C:\Users\Ciaran\Desktop\of_v0.7.4_win_cb_release\apps\examples\opeNI-SimpleExamples\bin\openNISample007.exe"  (in C:\Users\Ciaran\Desktop\of_v0.7.4_win_cb_release\apps\examples\opeNI-SimpleExamples\bin)