Problem when installing oF on Ubuntu 11.10

Hello,

i am encountering this problem when running install_dependencies.sh

  
  
mkdir -p obj/Debug/openFrameworks/gl  
g++ -g3 -Wall -fexceptions -I../../../FreeImage/include -I../../../assimp/include -I../../../assimp/include/Compiler -I../../../cairo/include -I../../../cairo/include/cairo -I../../../cairo/include/pixman-1 -I../../../cairo/include/libpng15 -I../../../fmodex/include -I../../../freetype/include -I../../../freetype/include/freetype2 -I../../../freetype/include/freetype2/freetype -I../../../freetype/include/freetype2/freetype/config -I../../../freetype/include/freetype2/freetype/internal -I../../../freetype/include/freetype2/freetype/internal/services -I../../../glew/include -I../../../glew/include/GL -I../../../kiss/include -I../../../portaudio/include -I../../../rtAudio/include -I../../../tess2/include -I../../../poco/include -I../../../glu/include -I../../../openFrameworks/ -I../../../openFrameworks/gl -I../../../openFrameworks/3d -I../../../openFrameworks/video -I../../../openFrameworks/utils -I../../../openFrameworks/types -I../../../openFrameworks/sound -I../../../openFrameworks/events -I../../../openFrameworks/math -I../../../openFrameworks/app -I../../../openFrameworks/communication -I../../../openFrameworks/graphics   -MMD -MP -MFobj/Debug/openFrameworks/gl/ofFbo.d -MTobj/Debug/openFrameworks/gl/ofFbo.d -o obj/Debug/openFrameworks/gl/ofFbo.o -c ../../../openFrameworks/gl/ofFbo.cpp  
In file included from ../../../openFrameworks/utils/ofConstants.h:113:0,  
                 from ../../../openFrameworks/math/ofVec2f.h:5,  
                 from ../../../openFrameworks/math/ofVec3f.h:3,  
                 from ../../../openFrameworks/types/ofPoint.h:3,  
                 from ../../../openFrameworks/gl/ofTexture.h:3,  
                 from ../../../openFrameworks/gl/ofFbo.h:3,  
                 from ../../../openFrameworks/gl/ofFbo.cpp:1:  
../../../glew/include/GL/glew.h:1172:20: schwerwiegender Fehler: GL/glu.h: Datei oder Verzeichnis nicht gefunden  
Kompilierung beendet.  
make: *** [obj/Debug/openFrameworks/gl/ofFbo.o] Fehler 1  
  
  

Any ideas what to do?

Thanks
Peter

it seems like glu.h it is not installed. Try to install from Synaptic libglu1-mesa and libglu1-mesa-dev or launch in a terminal:

sudo apt-get install libglu1-mesa libglu1-mesa-dev

let us know if this solved the issue.

No that throws a different error:

  
  
Hängt ab von: libglu1-mesa (= 7.11-0ubuntu3.2) aber 7.11.2~oneiric~ppa1.2 soll installiert werden  
                    Hängt ab von: libgl1-mesa-dev soll aber nicht installiert werden oder  
                                   libgl-dev  
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.  
  
  

Thats means more or less the version of the dev packet does not fit to my Ubuntu Version.

Strange.

it seems like you have installed some packages manually and now your repo is broken somehow. try installing the dependency, libgl-dev instead of libglu1-mesa. also if you do:

export LC_ALL=C

and then run the apt-get commands the output will be in english making it much easier to help you to solve the problem