Problem running compilePG in Ubuntu 22.04

I’m trying to install OF on my Ubuntu Linux (22.04) but I keep reaching to dead end. I have successfully installed the OpenFrameworks (ver. 0.11.0) using the script, but the Project Generator program compilation when using the script, keeps complaining with the following error:

Compiling projectGenerator for Release
make[1]: Entering directory '/home/koutras/_openbci/of_v0.11.0_linux64gcc6_release/apps/projectGenerator/commandLine'
/home/koutras/_openbci/of_v0.11.0_linux64gcc6_release/libs/openFrameworksCompiled/project/makefileCommon/ *** missing separator.  Stop.
make[1]: Leaving directory '/home/koutras/_openbci/of_v0.11.0_linux64gcc6_release/apps/projectGenerator/commandLine'
make: *** [/home/koutras/_openbci/of_v0.11.0_linux64gcc6_release/libs/openFrameworksCompiled/project/makefileCommon/ Release] Error 2
make: Leaving directory '/home/koutras/_openbci/of_v0.11.0_linux64gcc6_release/apps/projectGenerator/commandLine'
There has been a problem compiling the command line projectGenerator.
Please report this problem in the forums.

My make version is 4.3. Any thoughts?

Hi, welcome to the community.

I think the issue is that OF 0.11.0 is too old for 22.04

We’re currently recommending people use the nightly version of OF.

Can you try the linux64 release and make sure to run the two scripts in OF/scripts/linux/ubuntu/ ?


Thanks Theo! Unfortunately my purpose is to compile another program with OF (emotibit) and this requires v 0.11.0 and not the latest. I have read somewhere that this might be caused by the make version (needs a downgrade from v 4.0) but I’m not sure enough to try it. The release that I I have tried is the linux64.

Hmm anything that requires 0.11.0 should also work for 0.11.2 ( and that might fix the issue you are having ). 0.11.2 was basically a bugfix release of 0.11.0 and def should work for emotibit if 0.11.0 does.

However in terms of the error. The line it errors at is this one:

Which points to the addons specified in addons.make - does the commandLine/ folder have an addons.make file?

Did you download the 0.11.0 release or did you try setting it all up from Git?

Also another helpful test is to see if examples run:

cd examples/3d/3DPrimitivesExample/
make Release && make RunRelease 

Does that work?

If so you might be able to manually setup the project without the projectGenerator .

Dear Theo, I have downloaded version 0.11.2 and installed it as you have suggested with no problems. All examples can be compiled successfully and run error-free, including the one that you have mentioned. However, compiling the Emotibit-Oscilloscope app gives me errors, but that is something that I have to discuss in the Emotibit forum I guess. For reference, the error I get is the following:

/usr/include/c++/11/bits/stl_uninitialized.h:138:72: error: static assertion failed: result type must be constructible from value type of input range
  138 |       static_assert(is_constructible<_ValueType2, decltype(*__first)>::value,

Thank you very much for your help!

If you share the lines/output before that error and after that might help track it down.

It sounds like it might be something with the constructor for one of the Emotibit classes needing a small fix ( see c++ - "result type must be constructible from value type of input range" when trying to push stack<unique_ptr> (or deque) into a vector - Stack Overflow )

Or maybe a class that is inheriting another class but not publicly

But the output log might help narrow it down.

Glad everything else is working :slight_smile:

Theo, this is the complete output of the compilation procedure. Any hints, highly appreciated!
(below the link with the complete output of the compiling procedure).

Compiling output of EmotibitOscilloscope

look at late 1253 of ofApp.cpp ofApp.cpp:1253

1 Like

Looks like there is a resize, but the vector elements are being used without being allocated.

A better way would be to change that line to:

guiPanels.assign(6, ofxPanel());
1 Like

Couldn’t get it to work with this changes. However, the Emotibit development team () pointed out this branch for OF v.11.0.2 that I tested and worked without problems.
So, I think the problem is solved!
Thank you very much for your help!

1 Like