Problem ofxGSTRTP

Now I have problem of running ofxGSTRTP examples from @arturo
video_aduio example is running in my same network ( iptime router).
This is ok.

But, other example using talk.google is not working.
First, when ruing video_audio example in this computer, other computer’s gmail address is strange.
Like this, 0r9eksl87nnb531utujfo8znz2@public.talk.google.com/800E9C87
And Second,
Even if fist situation, I think the connection is ok because of “state AcceptingRTP” message.

But, call is not working.

is it “stun server” problem? or my network problem?

the weird id in the google id is because somehow google seems to do that unless you are friended on google+ (i think) or use the old gui to send an invitation. you can also use other xmpp servers there’s several public servers or you can even install your own.

the failure in the connection might be related with the STUN server, try a different one, both computers have to use the same. and also depending on the network you are connected from STUN is not enough and you need a TURN server

Thanks, you are right.
Other google id is friended on google +. so I send an invitation of just chat service using old gui.
Now, appeared google id works fine.

I don’t know much about server setting or network communication. Actually I don’t know how to set my server.
Just I use commercial web hosting for my homepage. But, I need server hosting right?
So, I want to set your example even on other network.
How to make my own server?
Server, hosting, DNS … etc those are confused .

Anyway.
Can I use public XXMP?
I used public XMPP using jabber.at . But other id is now showing up.
Is this also same with google id? Two XMPP server client id are friended each other?
but, I don’t know how. I can’t find friend addition at jabber.at .
Should I use some client software providing public XMPP chat service for friending?

And
But, Connection is not ok.
Now I got a message as follow. Remote session is accepted. but nice is failed.
nozvonham@gmail.com/73E67628 to state SessionAccepted
[ error ] video: nice failed for component 1
[ error ] video: nice failed for component 2
[ error ] video: nice failed for component 3
[ error ] audio: nice failed for component 1
[ error ] audio: nice failed for component 2
[ error ] audio: nice failed for component 3
[ error ] depth16: nice failed for component 1
[ error ] depth16: nice failed for component 2
[ error ] depth16: nice failed for component 3
[ error ] osc: nice failed for component 1
[ error ] osc: nice failed for component 2
[ error ] osc: nice failed for component 3

Two computers in same network didn’t show [ errrors ] message.
But,
Two computers in other network show [ errrors ] message.
Why different?
and in other network gave those error.
the failure is related with STUN or TURN , right?

So much question

Thanks