Problem ofImage and PNGs

Not sure if this is a bug but using 007 from git and trying to load a png using ofImage produces:
“OF: OF_LOG_WARNING: ofImage - getTextureReference - texture is not allocated”.

The images are in the data folder and I even tried loading the “imageLoaderExample” and it also has the same problem.

I tried also saving the image as a jpg and that worked fine. Did something change in ofImage in the way it handles transparent data?

Here’s an example that illustrates the problem:

  
#include "testApp.h"  
  
//--------------------------------------------------------------  
void testApp::setup(){  
	img.loadImage( "transparentImg.png" );  
}  
  
//--------------------------------------------------------------  
void testApp::update(){  
}  
  
//--------------------------------------------------------------  
void testApp::draw(){  
	img.draw( 0, 0);  
}  
  

  
#pragma once  
  
#include "ofMain.h"  
  
class testApp : public ofBaseApp{  
  
	public:  
		void setup();  
		void update();  
		void draw();  
		  
		  
		ofImage img;  
};  
  

EDIT: for grammar and spelling.

Its a bug. Theres 2 copies of the same library and are clashing in some way. If you remove libpng15 from libs/cairo/osx/lib it will work

That worked great.
Thanks Arturo!

Is this still valid? I am running into the same issue but I don’t see a way to remove libpng15