Problem install in Raspberry Pi 2


#1

Hi,

I followed the instructions from the website but when I tried to install the dependencies I have problems with this:

Err http://mirrordirector.raspbian.org/raspbian/ jessie/main libtiffxx5 armhf 4.0.3-12.3+deb8u2
404 Not Found [IP: 93.93.128.193 80]
Err http://mirrordirector.raspbian.org/raspbian/ jessie/main gir1.2-gtk-2.0 armhf 2.24.25-3+deb8u1
404 Not Found [IP: 93.93.128.193 80]
Err http://mirrordirector.raspbian.org/raspbian/ jessie/main libavutil-dev armhf 6:11.8-1deb8u1+rpi1
404 Not Found [IP: 93.93.128.193 80]
Err http://mirrordirector.raspbian.org/raspbian/ jessie/main libavresample-dev armhf 6:11.8-1deb8u1+rpi1
404 Not Found [IP: 93.93.128.193 80]
Err http://mirrordirector.raspbian.org/raspbian/ jessie/main libavcodec-dev armhf 6:11.8-1deb8u1+rpi1
404 Not Found [IP: 93.93.128.193 80]
Err http://mirrordirector.raspbian.org/raspbian/ jessie/main libavformat-dev armhf 6:11.8-1deb8u1+rpi1
404 Not Found [IP: 93.93.128.193 80]
Err http://mirrordirector.raspbian.org/raspbian/ jessie/main libswscale-dev armhf 6:11.8-1~deb8u1+rpi1
404 Not Found [IP: 93.93.128.193 80]
Err http://mirrordirector.raspbian.org/raspbian/ jessie/main libgtk2.0-dev armhf 2.24.25-3+deb8u1
404 Not Found [IP: 93.93.128.193 80]
Err http://mirrordirector.raspbian.org/raspbian/ jessie/main libjasper-dev armhf 1.900.1-debian1-2.4+deb8u2
404 Not Found [IP: 93.93.128.193 80]
Err http://mirrordirector.raspbian.org/raspbian/ jessie/main libtiff5-dev armhf 4.0.3-12.3+deb8u2
404 Not Found [IP: 93.93.128.193 80]
Err http://mirrordirector.raspbian.org/raspbian/ jessie/main libudev-dev armhf 215-17+deb8u6
404 Not Found [IP: 93.93.128.193 80]
E: Failed to fetch http://mirrordirector.raspbian.org/raspbian/pool/main/t/tiff/libtiffxx5_4.0.3-12.3+deb8u2_armhf.deb 404 Not Found [IP: 93.93.128.193 80]

E: Failed to fetch http://mirrordirector.raspbian.org/raspbian/pool/main/g/gtk+2.0/gir1.2-gtk-2.0_2.24.25-3+deb8u1_armhf.deb 404 Not Found [IP: 93.93.128.193 80]

E: Failed to fetch http://mirrordirector.raspbian.org/raspbian/pool/main/liba/libav/libavutil-dev_11.8-1~deb8u1+rpi1_armhf.deb 404 Not Found [IP: 93.93.128.193 80]

E: Failed to fetch http://mirrordirector.raspbian.org/raspbian/pool/main/liba/libav/libavresample-dev_11.8-1~deb8u1+rpi1_armhf.deb 404 Not Found [IP: 93.93.128.193 80]

E: Failed to fetch http://mirrordirector.raspbian.org/raspbian/pool/main/liba/libav/libavcodec-dev_11.8-1~deb8u1+rpi1_armhf.deb 404 Not Found [IP: 93.93.128.193 80]

E: Failed to fetch http://mirrordirector.raspbian.org/raspbian/pool/main/liba/libav/libavformat-dev_11.8-1~deb8u1+rpi1_armhf.deb 404 Not Found [IP: 93.93.128.193 80]

E: Failed to fetch http://mirrordirector.raspbian.org/raspbian/pool/main/liba/libav/libswscale-dev_11.8-1~deb8u1+rpi1_armhf.deb 404 Not Found [IP: 93.93.128.193 80]

E: Failed to fetch http://mirrordirector.raspbian.org/raspbian/pool/main/g/gtk+2.0/libgtk2.0-dev_2.24.25-3+deb8u1_armhf.deb 404 Not Found [IP: 93.93.128.193 80]

E: Failed to fetch http://mirrordirector.raspbian.org/raspbian/pool/main/j/jasper/libjasper-dev_1.900.1-debian1-2.4+deb8u2_armhf.deb 404 Not Found [IP: 93.93.128.193 80]

E: Failed to fetch http://mirrordirector.raspbian.org/raspbian/pool/main/t/tiff/libtiff5-dev_4.0.3-12.3+deb8u2_armhf.deb 404 Not Found [IP: 93.93.128.193 80]

E: Failed to fetch http://mirrordirector.raspbian.org/raspbian/pool/main/s/systemd/libudev-dev_215-17+deb8u6_armhf.deb 404 Not Found [IP: 93.93.128.193 80]

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?


#2

Looks like your internet connection is not working.


#3

My raspberry has internet connection. I tried using chrome go in to “http://mirrordirector.raspbian.org/raspbian/pool/main/g/gtk+2.0/” and when I tried to find one of the link for example “gir1.2-gtk-2.0_2.24.25-3+deb8u1_armhf.deb” I don’t find it. So I don’t know if is an internet problem.


#4

What happens if you do the following?

sudo apt-get update 

Do you get errors?


#5

You should be able to access http://93.93.128.193 in your browser on the pi (you should see a directory of files).

You should also be able to run

ping 93.93.128.193

From the pi command line. If either fail you likely have some kind of internet connection problem.


#6

No, no error.

Reading package lists... Done


#7

About run the ping

PING 93.93.128.193 (93.93.128.193) 56(84) bytes of data.
64 bytes from 93.93.128.193: icmp_seq=1 ttl=49 time=217 ms


#8

If you run the install scripts again do you still get the same error?


#9

I read a lot of people have the same problem and for fix it the best option is installing raspbian NOOBS, so I did it and works fine. Thanks for everything.


#10

Out of curiosity, what version Pi and openFrameworks were you trying to use? I’m very often working with RPI3 (ARMv6) and 0.9.8 and haven’t had any issues whatsoever.


#11

Hello, I had the same issue but after sudo apt-get update it works for me.

Thanks,
G.