Problem compiling v0.9.1 (armv6) on RPi2

I ran into several problems compiling OF on an RPi2 with a fresh image of Raspbian Jessie Lite (same issues on Jessie). Hope this helps people with similar issues, as these are not documented in the RPi installation guide.

First, RPI_ROOT doesn’t seem to be set, so the check for the arm version is not triggered, and it goes to look for armv7 and of course cannot find it. Then, for some reason the GST_VERSION is always set to 0.10 even though 1.0 is installed. This results in some gstreamer packages in pkg-config not being found. These can be fixed by setting the variables explicitly:

export RPI_ROOT=/
export GST_VERSION=1.0

Then, it starts compiling but run into this error:

make[2]: /opt/cross/bin/arm-linux-gnueabihf-g++: Command not found

Since I’m not cross compiling, that directory doesn’t exists. For this problem though, exporting CROSS_COMPILING=0 doesn’t seem to work, even though the variable is there. But adding it to the make command works:

make Release CROSS_COMPILING=0

After these changes, it compiles OF and and I tried a couple of projects. One thing I still haven’t figured out is that even though the OF library has been compiled, when compiling individual projects, quite a few of the OF files are recompiled. Is there anyway not to recompile them?

I opened an issue for this but as a temporary workaround the simplest way is

make IS_RASPBIAN=1

Thanks, that’s good to know.

1 Like

Unfortunately, none of the workarounds work for me. It won’t compile on my Pi2 regardless of IS_RASPBIAN or CROSS_COMPILING variables set. I always get the unsupported platform error.