Problem compiling for iPad Air

Hi !

I tried to re-compile a project I’ve done a few months back on an iPad Air. Back then there was no problem but now I’m getting errors about the architecture.

file was built for archive which is not the architecture being linked (armv7)

I then checked Unable to compile 0.8.4 for iOS using Xcode 6.1.1, OS 10.10.2 on 64-bit iPad Air 1, tried the different steps described but still couldn’t get it to work. So I downloaded https://github.com/danoli3/openFrameworks/tree/Apothecary/0.9.0-All and this is where I am now, getting this error on “ofConstants.h”:

Lexical or Preprocessor Issue 'unordered_map' file not found

Can somebody help ? Thx

Okay I found this post: [SOLVED] Linker errors with OpenCV 64bits

But now I get new errors in “ofMainLoop.h”:

No member named 'allowsMultiWindow' in 'ofAppBaseWindow'

(same for ‘doesLoop’ and ‘needsPooling’)

I use the master branch of git version.
It works fine for me at ipad air 8.3.

I had the same problem mentioned before with the master branch but I got it to work in the end… now it’s time to change my code to get things back on track (lot of deprecated stuff)

Thx anyway !

Hello!
I have the same problem… And I actually don’t find a way to solve it. How did you do ?
I m using the master github sources to compile for iOS.
Daily git pull to keep it up to date.

If I remember correctly, I was getting this error but was able to get it working after changing the “Deployment Target” and device type under the General tab and Deployment info… Try that and see if it works.

Hi. To build oF for iOS follow these steps:
1- Download nightly builds

2- Create your project with projectGenerator_ios and open in xcode
3- See pics :

Build and have fun with oF :wink: