Problem building with Qt Creator & msys (64bit) on Windows

Hi,

I think I have followed the instructions (https://openframeworks.cc/setup/msys2/ & https://openframeworks.cc/setup/qtcreator/) very carefully. And while I can build & run the example oF projects from the MSYS 64 shell, I get the following error when trying to build through Qt Creator:

“*** couldn’t find cairo zlib openssl glew glfw3 libcurl openal sndfile libmpg123 0 pkg-config package or it’s dependencies, did you run the latest install_dependencies.sh?. Stop.”

I have run the install_dependencies script multiple times in the msys 64 shell, and it reports that there is nothing left to do. I also think that since I can build the examples from the shell, it shows that the dependencies are actually installed.

The particular versions I am trying to use are:
msys2-x86_64-20190524 (installed at C:\msys64)
of_v0.11.0_msys264_release (installed at C:\msys64\home\Martin\of_v0.11.0_msys264_release)
Qt Creator 4.6.1 (installed at C:\Qt\qtcreator-4.6.1)
On a Windows 10 system

I have tried adding the following paths to my windows PATH variable (in all possible combinations):
C:\msys64\mingw64\bin
C:\msys64\mingw32\bin
C:\msys64\usr\bin
C:\msys64\home\Martin\of_v0.11.0_msys264_release\

My Qt Creator kit settings can be seen in the screenshot below:

I have also tried changing the sysroot variable to so many different locations, as well as tried adding the various path folders and MSYSTEM=MINGW64 and MSYSTEM=MINGW32 to the environment variable.

I have tried reinstalling from fresh a few times, as well as installing on an entirely different Window 10 pc, and the problem is recreated each time. I have run out of things to try, and would greatly appreciate any help from more knowledgeable users.

Thanks,
Martin

have you run the install_codecs.sh script as well? i think this might not be very well specified in the docs but the qtcreator projects won’t work without that

Thanks for you reply @arturo,

I don’t see any “install_codecs.sh” anywhere in the ‘of_v0.11.0_msys264_release’ folder (I did a search).
Where should it be located?

I was looking at the Qt Creator compile output (see below):

And I can see that something in the build process is trying to find the library packages in /mingw32/ even though it should be looking in /mingw64/. I did not run the “install_dependencies.sh” from the MSYS 32-bit shell - so there is nothing for it to find in /mingw32.

What could be set incorrectly that would cause Qt Creator to look in the 32-bit folder?

Reposting my solution from another thread here:

I had the same issue, but now it is working for me.

While checking libs\openFrameworksCompiled\project\msys2\config.msys2.default.mk i noticed that you need to set the MINGW_PREFIX environment variable.

My environment settings for my msys2(64) kit in qt creator look like this:

MINGW_PREFIX=/mingw64
MSYSTEM=MINGW64
PATH=D:\msys64\mingw64\bin;D:\msys64\usr\bin;${PATH}