Poco JSON folder missing error

#1

Hello,

I am running OF 0.10 on a Raspberry Pi 3 A+ with Raspbian Stretch lite (version from 2019-04-08).
This is a fresh install and I followed the getting started guide and executed the dependencies script.

I am trying to run ofxSMTP example, which uses ofxPoco and JSON and I get compilation error:

Poco/JSON/Object.h: No such file or directory

Looking at the folder /usr/include/Poco, I see that I don’t have JSON folder in there.

I checked the /usr/include/Poco/Version.h file and this what I have:

  • On this Raspberry: 0x01070600
  • Whereas on my Windows machine I have: 0x01090000

How can I fix this? Should I update poco using apothecary scripts?

Thanks

Cross-compile OF 0.10 for Raspberry Pi Armv6 Guide
#2

Looking at this site: http://www.raspberryconnect.com/raspbian-packages-list/item/109-raspbian-libdevel, it seems that Poco v1.7 is the latest for Rasbian Stretch.

libpoco-dev
Buster:(1.9.0-5+b1) Stretch:(1.7.6+dfsg1-5+deb9u1) C++ Portable Components (POCO) Development files

I will test with Rasbian Buster and see if that works.

#3

Installing Raspbian Buster and following instructions in this post solve the problem.

All good now :blush: