"Please select a platform first."

I am trying to update my project with a new addon, when I run the project generator now, for some reason the platforms box is greyed out without a platform selected. (I think in the past it had OS X (xcode) automatically selected). When I try to click update without a selected platform it says, “Please select a platform first.” However, since it is greyed out I cannot select a platform.

I’ve never seen that. Are you running OF 0.11.0?

@mfowler Try clicking the configuration button in the top right of the project generator window, and select advanced options. That should enable the platform dropdown so you can select the correct option