Playing Movie in iOS app. Sound but no image. GLES error?

HI Everyone,
I thought I was doing something simple. Simply trying to play a movie via an OF app on a tablet.
Movie loads and moves forward, I hear the sound playing. But screen is black.

This is the error message that I’m getting every frame.

[ error ] ofxiOSVideoPlayer::initTextureCache(): Error at CVOpenGLESTextureCacheCreateTextureFromImage -6661

I’ve tried fiddling with different codecs for my movie. I’ve tried adjusting iOs window settings, retina on/off, E1,E2 render setting. etc. I’m using Xcode. Building it both to my Mac and to a tablet, (iPad Pro, with iOS 15.5)both have the same problem, I hear sound, but just a blank screen. Not sure what I’m doing wrong or where to look. I’ve copied this more or less from the movie player example in the iOS examples. (Which does work both on my Mac and the tablet)

Not sure where to look now? Maybe Xcode settings, maybe AVFouundation. I’m a bit lost.
thanks for all pointers. Chris

------code here—
in header file.

ofxiOsVideoPLayer video;

in ofApp
void ofApp::setup(){
ofSetFrameRate(25);
video.load(“test2.mp4”);
video.play();
}

void ofApp::update(){
video.update();
}

void ofApp::draw(){
video.getTexturePtr()->draw(0,0);
}