Playback of video streams in ofx

I want to load movie streams from various sources and I have used this in setup():

myMovie.loadMovie("http://megahdlive1-f.akamaihd.net/i/live_1@105260/master.m3u8");
myMovie.play();

and then this in draw():

myMovie.draw(20,20);

The problem is that some streams work straight out of the box and others don’t.

For example these work:

rtmp://hprt.flashcloud.mediacdn.com/hprt/live
http://megahdlive1-f.akamaihd.net/i/live_1@105260/master.m3u8

but these don’t (even though I know they contain streams):

rtmp://213.16.167.187:1935/live
http://www.youtube.com/watch?feature=player_embedded&v=rOZgSsBTdZk

The latter is a live youtube feed.

Any idea:
why some rtmp feeds don’t work inside ofx?
how to use a live youtube feed inside an ofx program?

Thanks for the help

What platform are you using?

I am using Linux (ubuntu + debian).

I got some videos working since I last wrote but still not those. Check out:

http://www.livetvgreece.com/2012/05/3.html

if you see the source you can see the rtm sources but i can’t get them to work within ofx.

Some of the other streams are flash-based (like the youtube one). Is there any chance with those?

cheers

most of the links you post are web pages, html, that contain embeded video not videos in themselves, you would need to find the uri to the video to actually play it, gstreamer won’t be able to find the video inside a page and play it.

Thanks Arturo,
you are right the youtube page i posted is an html page.

http://www.youtube.com/watch?feature=player_embedded&v=rOZgSsBTdZk

It contains this stream.

Nevertheless, if I run it it does not load the stream it says:

[warning] ofGstVideoUtils: update(): ofGstVideoUtils not loaded
[warning] ofGstUtils: getDurationNanos(): couldn’t query time duration
[ error ] ofGstVideoUtils: buffer_cb(): error on new buffer, buffer size: 307200!= init size: 306720

Same with this one.

Any ideas?

Thanks.

I am adding to my own question.

Here are two strems:
http://206.222.31.146/mega
http://206.222.31.146/skai

that play fine in VLC but when I open them in openFrameworks nothing happens.

Any ideas?

Hey Arturo,
thank you for your earlier reply. I found a previous post where you said tha if a stream plays in totem (linux) it should play in ofx because it uses gstreamer. I posted two streams:
http://206.222.31.146/mega2
http://206.222.31.146/skai
which play in totem just fine, but still do not do anything in ofx (other streams play fine, but many are like the above).
Any tips?