pkg-config issues

When i try to build openFramworks as stated in :

l) Compile OF:

In the left part of the window, select the openFrameworks project and from the toolbar or the menu build the Android target.

i get the following in the eclipse console.

  
  
**** Build of configuration Android for project openFrameworks ****  
  
make android -C../openFrameworksCompiled/project/android   
/bin/sh: pkg-config: command not found  
/bin/sh: pkg-config: command not found  
make DebugAndroid  
make[1]: Nothing to be done for `DebugAndroid'.  
make ReleaseAndroid  
make[1]: Nothing to be done for `ReleaseAndroid'.  
make Release_arm7Android  
make[1]: Nothing to be done for `Release_arm7Android'.  
  

yet, in Terminal, if i run the following:

  
Bruno-Gustavos-MacBook-Pro:~ bgc$ pkg-config --list-all  
opencv OpenCV - Open Source Computer Vision Library  
  

any tips on how to solve this?

Hi Bruno,

I’m having the same problem above. Did you find any solution to solve this issue?

Please, let me know. If I found something I post here.

Cheers

i’ve been a little busy with college, so i haven’t looked into it since the post.

Alright, I’ve sent the message on OF+Android post. Let’s see.

Hi guys,

I had the same problem. I spent some time figuring out how to solve it. Here mi conclussions:

  1. Make sure you choose “Android” instead “Linux” on the build icon (the hammer). There’s an arrow where to expand the build options (Android vs Linux).
  2. After that you will still have the same error, but it won affect to the build and installation on the device.

It worked for me thus I recognize it’s pretty annoying.