pkc-config error and eclipse external tool doesn't work

i’m using the latest master from github and setup eclipse like shown in the setup guide on github

i get “/bin/sh: pkg-config: command not found” even though i set the target to Android and not Linux

Also when i want to test an example and click on the play button with toolbox (which runs the external Android INstall tool) it progresses until 35% and then i get the following error:

"‘Launching Android Install’ has encountered a problem.

The file does not exist for the external tool named Android Install"

I’m using the latest versions of the needed tools (android ndk r6, android sdk r12, ant 1.8.2) and i’m on osx lion

by the way is there anyone who has already successfully got the oF/android/eclipse combination working on osx lion? maybe it’s a lion specific problem?

i remember that i had to change the target os of the openframeworks xcode project to 10.6 to get oF running on osx… maybe there’s a setting that has to be changed to get the android oF developing enviroment running on lion.

do you have xcode installed? it’s needed for having in the system tools like make

yes i already have oF working with xcode for developing desktop applications. downloaded the latest xcode version from the app store … after changing the target os in the base project to 10.6 all my projects compile without problems.

argh … big typo :smiley:

jonas$ pkg-config --list-all

output:

  
  
libssl     OpenSSL - Secure Sockets Layer and cryptography libraries  
Failed to open '/opt/local/lib/pkgconfig/formw.pc': No such file or directory  
popt       popt - popt library.  
Failed to open '/opt/local/lib/pkgconfig/panelw.pc': No such file or directory  
libidn     Libidn - IETF stringprep, nameprep, punycode, IDNA text processing.  
openssl    OpenSSL - Secure Sockets Layer and cryptography libraries and tools  
zlib       zlib - zlib compression library  
libcrypto  OpenSSL-libcrypto - OpenSSL cryptography library  
Failed to open '/opt/local/lib/pkgconfig/menuw.pc': No such file or directory  
libcurl    libcurl - Library to transfer files with ftp, http, etc.  
libusb-1.0 libusb-1.0 - C API for USB device access from Linux userspace  
Failed to open '/opt/local/lib/pkgconfig/ncurses++w.pc': No such file or directory  
Failed to open '/opt/local/lib/pkgconfig/ncursesw.pc': No such file or directory  
sqlite3    SQLite - SQL database engine  
  

pkg-config is not used at all for android, that means that eclipse is trying to compile the linux target, double check that the openFrameworks project is in the android target: select it in the bar in the left and then change the target.

i double checked the targets, but it was already set to android and it doesn’t compile… i mean theres the pkg-config error but also theres this other error window that pops up (described in my first post) when i build and i have no idea what it is even related to … wrong eclipse settings? wrong os? :smiley:

also when pressing the play button with the suitecaise for installing you have to select the project you want to install first. if you select the openFrameworks project or any other which is not an example it will try to run the AndroidInstall target on that project and won’t work.

yes i did it that way but it still doesn’t work

at the moment i’m trying to get it working on ubuntu but the android 007 package on openframeworks.cc doesn’t work as explained in the android guide:

it says you have to import OF/addons/ofxAndroid/ofAndroidLib but with the android package from the website eclipse can’t do an import because it doesn’t find a project in this folder.

then i tried to use the latest master from github instead and there eclipse was able to import the ofAndroidLib folder. right now eclipse is doing an “Android Library Update” which is at 20% but as soon as i know if it works with ubuntu (11.04) i’ll report back

ok at least on ubuntu it works, i can successfully run the examples on my htc desire.

but still no luck under osx

related thread:
http://forum.openframeworks.cc/t/android-download-missing-file/7004/0

Just for the record, as I found this several months ago and now I found it again, I manage to handle this error with this:

sudo ln -s /opt/local/bin/pkg-config /bin/pkg-config