Pi USB Soundcard Native Instruments DJ 8 error

Hello,

I’m trying to run the soundPlayerExample using the Native Instruments Audio 8 soundcard (usb) on Raspbian Jessie. I’m using the latest 0.9.0 build and the card has been recognized by the alsa driver. It is also possible to play a wav-file by using the terminal command aplay.

When executing the soundPlayerExample I get the following log:

AL lib: (WW) alc_initconfig: Failed to initialize backend "pulse"
AL lib: (EE) alsa_reset_playback: snd_pcm_hw_params_set_format(data->pcmHandle, hp, format) failed: Invalid argument
[ error ] ofOpenALSoundPlayer: loadSound(): couldn't generate source for "data/sounds/Singer1.wav": 40964 AL_INVALID_OPERATION
[ error ] ofOpenALSoundPlayer: loadSound(): couldn't generate source for "data/sounds/Singer1.wav": 40964 AL_INVALID_OPERATION
[ error ] ofOpenALSoundPlayer: loadSound(): couldn't generate source for "data/sounds/Singer1.wav": 40964 AL_INVALID_OPERATION
[warning] ofOpenALSoundPlayer: setMultiPlay(): sorry, no support for multiplay streams

When executing the audioOutputExample I get this message:

Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started

RtApiAlsa::getDeviceInfo: pcm device (hw:0,0) data format not supported by RtAudio.
RtApiAlsa::getDeviceInfo: pcm device (default) data format not supported by RtAudio.

[notice ] ofBaseSoundStream::printDeviceList:
[0]  [in:2 out:2] (default in) (default out)
[1]  [in:2 out:2]

Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started

RtApiAlsa::getDeviceInfo: pcm device (hw:0,0) data format not supported by RtAudio.
RtApiAlsa::getDeviceInfo: pcm device (default) data format not supported by RtAudio.
RtApiAlsa: dump hardware params just after device open:

ACCESS:  MMAP_INTERLEAVED RW_INTERLEAVED
FORMAT:  S24_3BE
SUBFORMAT:  STD
SAMPLE_BITS: 24
FRAME_BITS: 48
CHANNELS: 2
RATE: [44100 96000]
PERIOD_TIME: (229 495352)
PERIOD_SIZE: [22 21845]
PERIOD_BYTES: [132 131070]
PERIODS: [1 993)
BUFFER_TIME: (229 495352)
BUFFER_SIZE: [22 21845]
BUFFER_BYTES: [132 131070]
TICK_TIME: ALL
[ error ] RtApiAlsa::probeDeviceOpen: pcm device 0 data format not supported by RtAudio.

Perhaps someone could give me a hint how to solve this issue.