PG linux issue OF12

Got the OF12 install no issues there but when running » ./
i got this , i think i saw this happen once a long time ago but can’t seem to remember how to fix it

Compiling projectGenerator for Release
make[1]: Entering directory '/home/jacos/OF12/apps/projectGenerator/commandLine'
make[1]: *** No rule to make target '/home/jacos/of_v0.12.0-rc1_linux64gcc6_release/apps/projectGenerator/commandLine/src/main.cpp', needed by 'obj/linux64/Release/src/main.o'.  Stop.
make[1]: Leaving directory '/home/jacos/OF12/apps/projectGenerator/commandLine'
make: *** [../../../libs/openFrameworksCompiled/project/makefileCommon/ Release] Error 2
make: Leaving directory '/home/jacos/OF12/apps/projectGenerator/commandLine'
There has been a problem compiling the command line projectGenerator.
Please report this problem in the forums.

I just tried with a fresh download on Ubuntu/Mint.

cd /home/theo/Downloads/of_v0.12.0_linux64gcc6_release
cd scripts/linux

and it works fine for me.
Could you try with the 0.12.0 release and without renaming the folder?
As I see you have two different names in your output above.
/home/jacos/OF12 and /home/jacos/of_v0.12.0-rc1_linux64gcc6_release/

yup i had this one /home/jacos/of_v0.12.0-rc1_linux64gcc6_release/ but i delete it before i got the release one. i did what u mention and redo de folder to release and it work, maybe it was something todo with have previously install the RC1?

1 Like

oh - huh, yes that is very strange.
I wonder if it is due to the PG_OF_PATH being added to the bash profile?


yeah it might be, well it works now so on to the nexts
Thanks @theo

1 Like