PAID PROJECT: Developer needed to fix 2 bugs - experience with VDMX helpful

Hi there,

Im looking to hire an OF developer to resolve a couple issues I’m having with an application built for me by a friend. Unfortunately, the friend is unavailable to finish the project, so I need help to resolve the project, so I can move on.

The project involves interfacing with a VJ’ing software called VDMX, over OSC. So if you have ever worked with VDMX or tried sending data over OSC, that could be helpful.

I know one of the issues is definitely on the OF side, but cant be 100% certain the other is. I have the source code and can explain more details on request. I’ve written a description of the two issues below. These will probably get you 75% there. I can describe better with video, or screen-share over a zoom call.

Thanks for taking time to read this.




The application is a ‘sequencer’ - a simple timeline with programmable markers used to control an electro-mechanical art installation called the “Magnetic Letterpress”. For future reference, I call the OF app the “Letterpress App”.

When I hit ‘play’, the Letterpress App sends a signal to an Arduino Mega, which in turn controls the electronics that move 180 electric pistons up and down - each fitted with a rare-earth magnet on top, positioned underneath a layer of magnetic oil. As the pistons get near to the oil, the oil raises up into mounds, forming three-dimensional words. You can see a video of the installation in action here:

This video shows the Letterpress App, with a voice-over explaining how the OF app works:

The video of the installation shows a video projection located above the oil. The video is sent from VDMX. vidvox (dot) net

The objective is to use VDMX to serve the video and sound track, in time with the timeline in the Letterpress App. To do this I have to link VDMX to the Letterpress App over OSC.

This is where Im having a couple of problems.

Problem 1: I can get VDMX to look for an OSC signal, but its not looking for the right kind of signal. I believe this is something to do with how the signal is defined inside the OF Letterpress App. It should be looking for “OSC/time/change”, but is instead looking for "OSC/playback/setTime”. This connects the VDMX timeline with the LetterPress timeline, but only on manual scroll, not when I click ‘play’. I have a copy of an earlier version of the app which DOES work, and does look for “OSC/time/change”, so I know it is possible.

Problem 2: VDMX is not playing the video audio. The video image plays, but there’s no sound. I cant be 100% certain this is a problem with the Letterpress App, as I would expect the sound to at least manually scroll with the image. But then again, solving the first problem could solve both problems.

1 Like

Hi, do you still need help?
I am not super used to vdmx (i use modul8 & madmapper) but i think your issues should not be of a big problem for me to solve.
Please contact me under mail
Kind regards

P.S.: the sound issue is most certain in VDMX. The sound should be played when you manually play a sound in vdmx. The first issue is possibly something with the order multiple osc messages are sent.

I’ve used VDMX for a number of years and I can take a look at the issue. Message me here if you’d like.

Thanks for getting in touch guys.

The developer I was working with explained how to correctly link the OP app with VDMX, and now everything is working as intended. This was a big relief as I have been stuck for months now.

But if I ever need help with a new art project, I know where to look. Cheers!