osxVideoRecorderExample 0072 w/ Blackmagic Intensity Shuttle

I see that some others on here have had success working with Blackmagic devices and was hoping for some help getting mine up and running in OF. This is where I’m at so far …

  • Tested the device and camera with Blackmagic Media Express to make sure I’m getting video in.
  • Set the Blackmagic system preferences to use HD 1080p 24fps and use HDMI for both video and audio input.
  • Set the camera settings to 1080p 24fps.
  • Loaded up the osxVideoRecorderExample, set the device to the Blackmagic 1080p 24fps 8bit input.
  • Changed the frame rate to 24fps and initialized vidGrabber with a 1920x1080 resolution.
  • When I’d run the app from there all I get is black. I’d get a visual from other devices, but only black as I cycle through the Blackmagic ones.

Here’s the setup I’m using …

  • New mac mini running OSX 10.8 and XCode 4.5
  • Blackmagic Intensity Shuttle for Thunderbolt
  • Sony HDR-CX580V
  • OF v0072

I also tried running the ofxQTKitVideoGrabber example but wasn’t sure how to troubleshoot the error I was getting. In testApp.h it says ‘Field type “ofxQTKitVideoGrabber” is an abstract class’.

Any suggestions on figuring this all out would be appreciated.
Thanks,
Jeff

Hi Jef,

This is what worked for me using:

  1. BlackMagic UltraStudio Express Thunderbolt
  2. Incoming video stream pal 720/576
  3. using ofxQTKitVideoGrabber
  4. Mountain Lion (10.8)/ Xcode 4.5
  5. oF version 0071

Screenshot of the System Preferences: Blackmagic (the set video default standard is set to PAL)

Screenshot of the Preferences in BlackMagic Media Express (project video format is set to PAL)

This is the initialization of ofxQTKitVideoGrabber in the setup method:
vidGrabber.setDeviceID(0);
vidGrabber.initGrabber(720, 576);

Hope this can help.

try use list devices and then put the correct setting as your capture device (blackmagic capture formats appear as different devices, or try invoke the videoSettings() function once you are running, this will also let you select the correct device (read ‘setting’ for blackmagic capture devices).

This always works for me with blackmagic stuff.

Fred

Thanks for the replies. I’ve got a couple updates since I last posted. I encountered a new problem while I was troubleshooting the issues mentioned above. Started getting some results and then discovered that the Blackmagic Intensity Shuttle has problems with overheating and had to replace it with a Intensity Extreme. I still haven’t gotten 24p to work, but as long as I match the resolution and fps across the Blackmagic system settings and OF sketch I can get a few other configurations working. I’ve got something that’ll work for me now as I don’t need 24p. Still curious as to why it won’t work though. I’m running off of a SSD, so drive speed shouldn’t be an issue.

Pretty happy with the results I’m getting now though. Once I got a progressive setup working instead of interlaced the image quality has been great and the addition of 720 h264 compression in the new osxVideoRecorderExample produces a nice workflow with manageable file sizes.

Ok, I misunderstood what you were doing. I had not seen the video recorder example. I also tried every configuration I could with the blackmagic box and no joy- not a single frame. Did you end up getting it to work?