Orange Pi can't install libeglx-mesa-dev Mali driver error

Hi, I’m trying to install of on Orange Pi One with armbian. When i run install_dependencies.sh it show me the following errors:
Do you want to continue? [Y/n] y
(Reading database … 173628 files and directories currently installed.)
Preparing to unpack …/libegl1-mesa-dev_10.3.2-1+deb8u1_armhf.deb …
Unpacking libegl1-mesa-dev:armhf (10.3.2-1+deb8u1) …
dpkg: error processing archive /var/cache/apt/archives/libegl1-mesa-dev_10.3.2-1+deb8u1_armhf.deb (–unpack):
trying to overwrite ‘/usr/include/KHR/khrplatform.h’, which is also in package sunxi-mali-r3p0 4.0.0.0
Preparing to unpack …/libgles1-mesa-dev_10.3.2-1+deb8u1_armhf.deb …
Unpacking libgles1-mesa-dev:armhf (10.3.2-1+deb8u1) …
dpkg: error processing archive /var/cache/apt/archives/libgles1-mesa-dev_10.3.2-1+deb8u1_armhf.deb (–unpack):
trying to overwrite ‘/usr/include/GLES/glplatform.h’, which is also in package sunxi-mali-r3p0 4.0.0.0
Preparing to unpack …/libgles2-mesa-dev_10.3.2-1+deb8u1_armhf.deb …
Unpacking libgles2-mesa-dev:armhf (10.3.2-1+deb8u1) …
dpkg: error processing archive /var/cache/apt/archives/libgles2-mesa-dev_10.3.2-1+deb8u1_armhf.deb (–unpack):
trying to overwrite ‘/usr/include/GLES2/gl2platform.h’, which is also in package sunxi-mali-r3p0 4.0.0.0
Errors were encountered while processing:
/var/cache/apt/archives/libegl1-mesa-dev_10.3.2-1+deb8u1_armhf.deb
/var/cache/apt/archives/libgles1-mesa-dev_10.3.2-1+deb8u1_armhf.deb
/var/cache/apt/archives/libgles2-mesa-dev_10.3.2-1+deb8u1_armhf.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
error installing dependencies, there could be an error with your internet connection
if the error persists, please report an issue in github: http://github.com/openframeworks/openFrameworks/issues

Can somebody help me please?

Thanks!

I think. You already have different, proprietary gles2 drivers installed. Try removing gles2 from the of install script as a quick workaround.

OK, i deleted the libglX-mesa-dev packages that causes the conflict. Now i tried to compile polygonExample and y receive the following error:

root@orangepione:~/Downloads/of/examples/graphics/polygonExample# make
HOST_OS=Linux
checking pkg-config libraries:   cairo zlib gstreamer-app-1.0 gstreamer-1.0 gstreamer-video-1.0 gstreamer-base-1.0 libudev freetype2 fontconfig sndfile openal openssl libpulse-simple alsa gtk+-3.0 libmpg123 glesv1_cm glesv2 egl
/root/Downloads/of/libs/openFrameworksCompiled/project/makefileCommon/config.shared.mk:294: *** couldn't find some pkg-config packages, did you run the latest install_dependencies.sh?.  Stop.

I supposed that the compiler can’t find the graphics drivers. How can i specify this?

To make sure: you have removed libglX-mesa-dev from the install_dependencies.sh script? Because you already had different gles2 drivers installed?

No you actually have the same problem again within the makefile. I am not entirely sure what version of arm of will compile on your system. But you may have to remove gles2 here as well: https://github.com/openframeworks/openFrameworks/blob/master/libs/openFrameworksCompiled/project/linuxarmv7l/config.linuxarmv7l.default.mk#L70