OpenNI - EXC_BAD_ACCESS

Hey all,

I have been struggling and struggling to get openNi running for a few days now. I have poured over these forums in an unhealthy way.

I have:

  • updated oF to the latest git
  • got the Roxlu’s latest git for the ofxOpenNI addon
  • created the group in Xcode
  • imported the SRC and INCLUDE folders
  • added the search header “…/…/…/addons/ofxOpenNI/include/”
  • copied the COPY_TO_DATA_PATH folder to bin/data
  • dragged the dynlib file to my project

I have done these steps about 6324623874 times :wink: Right now I am getting a EXC_BAD_ACCESS error which doesn’t seem to tell me much about what is wrong.

If there is anyone out there that has been where I am with any advice… OR that may be able to take a look at my project it would be seriously appreciated.

http://barryswebsite.com/staging/kinect/openni.zip

Thanks guys.

looks like you are able to compile - that’s good.

is the file roxlu_posing.oni in the bin/data folder?

You’re absolutely right there was no oni file. I tried going back through all the different gits and branches and couldn’t find roxlu_posing.oni anywhere. I did manage to find SkeletonRec.oni from openni.org but it didn’t work either. Thanks for the help jvcleave.

If anyone comes across this thread I did however get this branch running http://forum.openframeworks.cc/t/openni-skeleton-tracking/5125/108

Hi Andehlu! I’m also stucked here with this EXC_BAD_ACCESS… did you manage to make it works?

Any suggestion to fix it?

Thanks!

Miguel