openGL Incorrect API Use | RenderDoc compatibility

Hi All. :grinning:

I’m trying to inspect\debug my program with RenderDoc and I can only get little few information.
The vertex information is missing, the buffers appear empty, cannot inspect attributes…

I realized that every OF project I run with RenderDoc has the following warning:
Warning! Core profile not explicitly required, compatibility profile is not supported.
And the error terminal is full of:
Incorrect API Use High Undefined 0 No vertex shader bound at draw!

I’ve tried other openGL projects (none OF ones) and the inspector runs smoothly.

Is anyone having similar issues?
Does anyone have experience using RenderDoc + OpenFrameworks?

Please, any comment on this?


// -----------------------------------------------------------------------------------
I’m running the OF github version at 0.11.0-master.
RenderDoc release 1.7.
Linux archlinux 5.6.6-arch1-1
Intel® Core™ i7-6500U
NVIDIA GeForce 940M

Hi :slight_smile:

This is running examples/shader/08_displacementMap through RenderDoc 1.7 with an Intel graphics 4600 on Arch Linux. Latest QtCreator but I haven’t updated OF since last year.

I don’t get that compatibility profile warning you are getting.

Could you try with the same shader example?

Hi @hamoid,
Thansk for your message.

Actually, that example runs without issues.
The window does not show the ‘Compatibility Profile’ Warning and I dont find errors on the console.
I can also inspect the buffers and the vertices looks correct.

Could you check the examples/3d/ofBoxExample example?
I do have the same issues, warning and error messages when I run my OF project I’m working on.

Greetings and thanks for your help.

Check out main.cpp. One of the examples activates OPENGL 3.2 and the other doesn’t :slight_smile:

Oh Yeah thanks.

ofGLWindowSettings settings;

When initializing the OF project with OpenGL 3.2, it does not trigger warnings and errors on RenderDoc.

Now I can inspecting my project and continue looking for a solution to the graphic glitches.

Thanks :slight_smile: