OpenGL 3.2 on OSX Big Sur

From my understanding mac osx 1’.14 big sur has discontinued the support for openGL 3.2 (https://developer.apple.com/library/archive/documentation/GraphicsImaging/Conceptual/OpenGL-MacProgGuide/opengl_intro/opengl_intro.html) ì, the fact is that all my shaders are written in opengl3.2 and I only own mac devices…

so my question is there is a way to resurrect all y work and get it to run on mac again?

1 Like

OpenGL 3.2 is supported on all recent macOS versions.
The note just means that they are not going to support future OpenGL versions and maybe at some point they will drop GL altogether ( thought that could still be quite a ways off ).

If you try the example in examples/gl/gpuParticleSystemExample/ and change the line setGLVersion in main.cpp to the commented out 3.2 it should work for you.

//========================================================================
int main( ){

    ofGLWindowSettings settings;
//    settings.setGLVersion(2, 1);  // Fixed pipeline
    settings.setGLVersion(3, 2);  // Programmable pipeline
    settings.setSize(1024, 768);
    ofCreateWindow(settings);
    if(!ofGLCheckExtension("GL_ARB_geometry_shader4") && !ofGLCheckExtension("GL_EXT_geometry_shader4") && !ofIsGLProgrammableRenderer()){
    	ofLogFatalError() << "geometry shaders not supported on this graphics card";
        return 1;
    }
    
    ofRunApp(new ofApp());

}

Nope still not working, I’m attaching an example project i still get errors

[ error ] ofShader: setupShaderFromFile(): couldn't load GL_VERTEX_SHADER shader  from "/Users/nicolabertelloni/Developer/of_v0.11.1_osx/apps/proofs/005 - shaders_execises/bin/005 - shaders_execisesDebug.app/Contents/Resources/../Resources/data/shaders/05_temperance/shader.vert"
[ error ] ofShader: setupShaderFromFile(): couldn't load GL_FRAGMENT_SHADER shader  from "/Users/nicolabertelloni/Developer/of_v0.11.1_osx/apps/proofs/005 - shaders_execises/bin/005 - shaders_execisesDebug.app/Contents/Resources/../Resources/data/shaders/05_temperance/shader.frag"
[ error ] ofShader: linkProgram(): trying to link GLSL program, but no shaders created yet

    

Hmm, that could be due to the spaces in your file paths.
Did you try the example I mentioned above?

If that gpuParticleSystemExample doesn’t work for you what errors do you get when you run that?

Thanks!
Theo