Openframeworks setup problem ubuntu

I am fallowing the instruction from this link http://openframeworks.cc/setup/linux-install/ but I am having problem.

Here what I did.
cd OF/scripts/linux/ubuntu
sudo ./install_dependencies.sh

If select NO then it continue until it shows.

It seems you are running gcc 5 or later, due to incompatible ABI with previous versions we need to recompile poco. This will take a while
Press any key to continue…

Downloading “poco”
SHA== github.com/pocoproject/poco
/home/jhovarie/Desktop/CurrentProjects/of_v0.9.8_linux64_release/scripts/apothecary/formulas/poco/poco.sh: line 36: curl: command not found

^ Received error ^
logname: no login name
chown: cannot access ‘build/poco’: No such file or directory

//----------------------------
If select YES it continue until it shows

Installing libgl1-mesa-dev-hwe-16.04
E: Unable to locate package libgl1-mesa-dev-hwe-16.04
E: Couldn’t find any package by glob ‘libgl1-mesa-dev-hwe-16.04’
E: Couldn’t find any package by regex ‘libgl1-mesa-dev-hwe-16.04’
error installing libgl1-mesa-dev-hwe-16.04
Reading package lists… Building dependency tree… Reading state information…
this seems an error with your distribution repositories but you can also
report an issue in the openFrameworks github: openframeworks/openFrameworks/issues

How to fixed this?

You could

sudo apt-get install curl

I think this is solved in oF 0.10, to be launched maybe next week.

1 Like

It works thanks you save my time.