openFrameworks IDE plugins


#41

nice find, can you test if my latest commit also fixes the problem?


#42

hi @arturo,

eclipse again:

I’m trying to create a new project. an example for an addon. so I’m using the path to the addon oF/addons/ofxNumEdit as the project root and give it a name (like oF/addons/ofxNumEdit/example-basic). now everything works fine except adding the addon itself to the projects property. it doesn’t show up. I can add any addon but not (in this case) ofxNumEdit. no error messages and “Ok” doesn’t close the dialogue.

I guess the problem is that in the project, in addons/ofxNumEdit it would create a reference to itself (because the examples are again listed there). is there a workaround for this or how do you setup your addon example projects?

btw.: is this stuff for the forum or github issues?

thanks,
felix


#43

yes the problem is that there’s a recursive reference as you’ve figured out. i’m planning to create a project template for addons but what i0’ve been doing is just creating the project in the addon root and then in the c++ config change the build directory to the example folder.

once i upload the source for this plugins to github we can move this issues there but by now let’s keep them in this post

btw, i was checking to change the minimum java version to 1.7 but then it won’t compile so i guess i’ll add a note in the docs


#44

@thomasgeissl, no. I’ve just downloaded the RC2. I’ve tried to import an existing project, 3dPrimitiveExample, but i can not see the files and i can not run the build, see image in attachment. I’ve also added the flags that @tactif suggested but without any improvement.
My clang version looks ok, the Auto detected one that you see in this screenshot is the same that I’ve under “Auto Detected” in the panel “Kits”.


#45

@tactif Your solution worked for me.
I still do not get why the property cpp.cxxLanguageVersion: "c++11" does not work.

@edapx Does it give you any errors listed under Issues?

I successfully imported and compiled an old app.
I simply had to add the missing files form the src directory. The wizard only adds {main.cpp, ofApp.h, ofApp.cpp}.
And I had to copy fmod library manually to ofApp.app/Contents/MacOS/.
@Arturo can this be automated?


#46

@thomasgeissl, sorry, my mistake. Closing Qt creator ad re-opening the same project with the changes to the .qbs file fixes the problem wth the invisibles files, and the “build” button is now enabled, is not grey as before.
Now I’ve another problem, the build does not run, I’ve this error in the Compile Output

3DPrimitivesExample/bin/3DPrimitivesExample_debug.app/Contents/MacOS/3DPrimitivesExample_debug
Undefined symbols for architecture x86_64:
OBJC_CLASS$_QTCaptureDevice”, referenced from:
objc-class-ref in libopenFrameworksDebug.a(ofQTKitGrabber.o)
OBJC_CLASS$_QTCaptureDeviceInput”, referenced from:
objc-class-ref in libopenFrameworksDebug.a(ofQTKitGrabber.o)
OBJC_CLASS$_QTCaptureMovieFileOutput”, referenced from:
objc-class-ref in libopenFrameworksDebug.a(ofQTKitGrabber.o)
OBJC_CLASS$_QTCaptureSession”, referenced from:
objc-class-ref in libopenFrameworksDebug.a(ofQTKitGrabber.o)
OBJC_CLASS$_QTCaptureVideoPreviewOutput”, referenced from:
OBJC_CLASS$_QTKitVideoGrabber in libopenFrameworksDebug.a(ofQTKitGrabber.o)
OBJC_CLASS$_QTCompressionOptions”, referenced from:
objc-class-ref in libopenFrameworksDebug.a(ofQTKitGrabber.o)
OBJC_METACLASS$_QTCaptureVideoPreviewOutput”, referenced from:
OBJC_METACLASS$_QTKitVideoGrabber in libopenFrameworksDebug.a(ofQTKitGrabber.o)
“_QTMediaTypeMuxed”, referenced from:
+[QTKitVideoGrabber listVideoDevices] in libopenFrameworksDebug.a(ofQTKitGrabber.o)


#47

@edapx Same problem here… I managed to get my own stuff compiled and running (an app only using ofxXmlSettings and ofxOsc), but tried with two examples without success… I get the same link errors than you


#48

I’ve just published the source for the visual studio and eclipse plugins:



#49

Hi Arturo,

I have encountered an error after confirming addons:

Exception from HRESULT: 0x80041FE2

Windows version: Windows 7 x64 Professional
VS version: VS Community 2015
Plugin version: 1.0 (downloaded from “Extensions and Updates”)
Clean download of OF0.9.0 with choosing default addons only, no downloaded addons

Any hints?


#50

i think it’s this same problem:

there’s a solution for it down in the post


#51

Yes it is the same problem, I was not prompted to install the tools.
Thanks a lot!