openFrameworks IDE plugins


#21

what version of OF are you using? there was a problem in today’s nightly and osx that i’ve just fixed in master, if you are using the nightlies you can fix it by copying the openFrameworksCompiled/project/qtcreator folder from master


#22

I just pulled the latest master and now I am getting:

Should we move over to github?


#23

can you try now? also i think you are creating the app only one level below openframeworks root, it should work now but it’w better to create it in:

openFramerworks/apps/myApps/ofQtAppTest6

instead of:

openFramerworks/apps/ofQtAppTest6


#24

I changed the location as suggested, now i am getting the following:


#25

did you changed the kit to use clang? by default it’ll use gcc which in osx is pretty outdated and won’t support c++11.

i’ll write all this down at some point :slight_smile:


#26

Yes, I did:

Anything else I could have done wrong?


#27

I just noticed it is greyed out. Not sure what that means.


#28

i have Manual > Desktop and there i’ve selected clang. you can also create a config from scratch if that doesn’t work but it worked for me right away


#29

I just configured a new kit, but it is giving me the same error. I will again give it try later and post some feedback.


#30

also if you can post the compiler output, mostly the command that it’s triggering the error, it’ll help finding out what’s going on


#31
In file included from /Users/thomasgeissl/programming/of/openFrameworks/apps/myApps/ofQtAppTest10/src/ofApp.cpp:1:
In file included from /Users/thomasgeissl/programming/of/openFrameworks/apps/myApps/ofQtAppTest10/src/ofApp.h:3:
In file included from /Users/thomasgeissl/programming/of/openFrameworks/libs/openFrameworks/ofMain.h:5:
/Users/thomasgeissl/programming/of/openFrameworks/libs/openFrameworks/utils/ofConstants.h:393:10: fatal error: 'unordered_map' file not found
#include <unordered_map>
         ^
1 error generated.
Process failed with exit code 1.
The following products could not be built for configuration qtc_Desktop__8b68ce34-debug:
	ofQtAppTest10
	openFrameworks
Error while building/deploying project ofQtAppTest10 (kit: Desktop Clang)
When executing step "Qbs Build"
15:10:41: Elapsed time: 00:08.

Looks like c++11 there is no c++11 support, but the compile command looks fine for me.

/usr/bin/clang++ -arch x86_64 -g -O0 -pipe -fvisibility=default -Wno-unused-parameter -std=c++11 -fPIC -DDEBUG -DGCC_HAS_REGEX -DOF_USING_GTK -DOF_USING_MPG123 -I/Users/thomasgeissl/programming/of/openFrameworks/libs/openFrameworks

If I build a qt widgets application and #include <unordered_map> I get the same error.
Adding CONFIG += c++11 to the .pro file solves this.
I am not familiar with qbs.
I tried adding cpp.cxxLanguageVersion: "c++11"and cpp.cppFlags: "-std=c++11". But both solutions gave me the same error.


#32

can you try if the latest commit in master fixes it for you?


#33

thanks @arturo,

I just installed the plugin for eclipse as described but even after restarting the plugin is not showing up as in your video - not in the create project dialogue and also not under Window > Preferences. installation went through without any errors and it is listed under Help > About > Installation Details.

just pulled oF master, using Eclipse CDT Mars1, under Ubuntu 14.04

any clues?

edit: problem might be independent of your plugin. found this http://stackoverflow.com/questions/2697882/plugins-installed-on-eclipse-not-visible and will try it out

update: no luck so far (with -clean, run as admin, install as admin, …) and no error messages with -consoleLog -debug. installed another extension (Lua SDK) which worked.

more infos: plugin showing up under Installation Details > Installed Software:

openFrameworks eclipse plugin 0.1.0.201510121850 cc.openframeworks.feature.feature.group openFrameworks

but not under Features or Plug-Ins.
In Installation Details > Configuration I found:
*** Plug-in Registry: cc.openframeworks.plugin (0.1.0.201510121850) "openFrameworks plugin" [Installed]

found it?: with the plug-in dev tools I found the entry Bundle-RequiredExecutionEnvironment: JavaSE-1.8 and my java version is 1.7. is this why?

nope: same problem after switching to 1.8

solved: reinstalling eclipse mars after switching to 1.8, not using the installer, new workspace

felix


#34

uh, so was this a requirement of the OF plugin or in general for eclipse plugins? i’m looking into my code but can’t find anything related to the jave version. otherwise i can try to set it to 7. from what i heard next version of eclipse will require java 8 though.


#35

It did not work for me.
@edapx you did not have this problem, right? Any idea what I am doing wrong?


0.9.0 Release Candidate 2
#36

found this entry in the META-INF/MANIFEST.MF in the Plug In Development perspective of your plugin. but don’t know anything about eclipse plug in development, so maybe not even shipped by you?


#37

I’m having the same problem… I’ve been through the same steps you did, everything seems fine, the right kit is selected, clang is selected in the kit (whilst being grayed) but I get this build error

/Volumes/Work1/Development/openFrameworks/libs/openFrameworks/utils/ofConstants.h:393: error: ‘unordered_map’ file not found

Did you find a solution ? You mentioned a .pro file but I could not find it anywhere…

BTW : I used git clone from openFramework repo 1 hour ago… Is it the right way to get the latest fixes of OF ?


#38

I haven’t found a solution yet, I gonna try tonight.
The .pro file i mentioned was from a non oF application I set up for testing.


#39

Adding this to .qbs file allow me to go through the whole build process

   of.cxxFlags: ["-std=c++11", "-stdlib=libc++"]         // flags passed to the c++ compiler
   of.linkerFlags: ["-lc++"]      // flags passed to the linker

#40

I’m on OSX, and THANKS GOD I hope I’ll be no more using Xcode in a couple of days !!! YEEEEEEEEEEEEEESSSSSSSSS ! :sunny: