Openframeworks.cc certificate not trusted raspberry pi


#1

I tried ‘wget https://openframeworks.cc/versions/v0.9.8/of_v0.9.8_linuxarmv6l_release.tar.gz’ of the OF distribution from my Pi3 with Rasbian4.14 (Stretch). SSH’d from Mac computer.

I got
ERROR: The certificate of ‘openframeworks.cc’ is not trusted.
ERROR: The certificate of ‘openframeworks.cc’ hasn’t got a known issuer.

Know if this Is a Pi issue? ‘Stretch’ OS issue, (they changed some approaches to permissioning in the new version of OS)? Server issue?

Are there workarounds?


#2

Is the time and date set correctly on your pi?


#3

No. I thought it wasn’t persistent and don’t update… do you mean the timezones, and other localization settings?


#4

I looked and the time is set correctly, since pi’s online. Also checked/redid the localizations.
Tried to ‘wget’ the file and same result.


#5

Hi,
I usually download the file on my computer and transfer the OF folder via SFTP (my Bitvise SSH client on Windows does that), then you just have to install.
I think you can find a tool like that on MacOS


#6

Thanks, That’s what I eventually did. You can use Fetch on Mac (a bit old school). I was worried that there might be permissioning issues, but didn’t seem to be.


#7

You might try this until OF fix their cert:

curl -k https://openframeworks.cc/versions/v0.10.0/of_v0.10.0_linuxarmv6l_release.tar.gz --output of_v0.10.0_linuxarmv6l_release.tar.gz


#8

Thanks @steeley. I had the same problem and using curl work for me!


#9

Hi, can anyone try if installing certificates fixes this issue:

sudo apt install ca-certificates

then wget or curl the file without -k. The openframeworks site certificates should be fine so it might just be that raspbian doesn’t come with certificates installed by default


#10

Tried it with Raspbian Jessie (RB 3B), and got ca-certificates is already the newest version.
Getting the same error as @Poltergeister and with curl
curl https://openframeworks.cc/versions/v0.9.8/of_v0.9.8_linuxarmv6l_release.tar.gz --output OF.tar.gz
I get this:

curl: (60) SSL certificate problem: unable to get local issuer certificate
More details here: http://curl.haxx.se/docs/sslcerts.html
curl performs SSL certificate verification by default, using a “bundle”
of Certificate Authority (CA) public keys (CA certs). If the default
bundle file isn’t adequate, you can specify an alternate file
using the --cacert option.
If this HTTPS server uses a certificate signed by a CA represented in
the bundle, the certificate verification probably failed due to a
problem with the certificate (it might be expired, or the name might
not match the domain name in the URL).
If you’d like to turn off curl’s verification of the certificate, use
the -k (or --insecure) option.