Openframeworks.cc certificate not trusted raspberry pi


#1

I tried ‘wget https://openframeworks.cc/versions/v0.9.8/of_v0.9.8_linuxarmv6l_release.tar.gz’ of the OF distribution from my Pi3 with Rasbian4.14 (Stretch). SSH’d from Mac computer.

I got
ERROR: The certificate of ‘openframeworks.cc’ is not trusted.
ERROR: The certificate of ‘openframeworks.cc’ hasn’t got a known issuer.

Know if this Is a Pi issue? ‘Stretch’ OS issue, (they changed some approaches to permissioning in the new version of OS)? Server issue?

Are there workarounds?


#2

Is the time and date set correctly on your pi?


#3

No. I thought it wasn’t persistent and don’t update… do you mean the timezones, and other localization settings?


#4

I looked and the time is set correctly, since pi’s online. Also checked/redid the localizations.
Tried to ‘wget’ the file and same result.


#5

Hi,
I usually download the file on my computer and transfer the OF folder via SFTP (my Bitvise SSH client on Windows does that), then you just have to install.
I think you can find a tool like that on MacOS


#6

Thanks, That’s what I eventually did. You can use Fetch on Mac (a bit old school). I was worried that there might be permissioning issues, but didn’t seem to be.