openFrameWorks build error make[1] .....Error 127 and Error 2

Please…
I am Taiwan Boy and English is not good…sorry

Problem:
I reference for >> http://www.openframeworks.cc/setup/android-eclipse/
but
Eclipse build of_v0.7.4_android_release/examples/android/[all sample]

Eclipse Console error message>>>
make[1]: *** [obj/DebugAndroid/openFrameworks/utils/ofUtils.o] Error 127
make: *** [android] Error 2

Development environment
1.Vmware play run Ubuntu12.04 64bit
2.java 1.6.0_27
3.ant 1.8.2
4.make 3.81
4.Eclipse IDE for C/C++ Developers linux 64bit
5.SDK (android-sdk-linux)
6.NDK (android-ndk-r9 64 bit)
7.of_v0.7.4_android_release
8.ADT

i change platform Ubuntu13 64bit and Mac OSX 18.8.4 ,but Error messages are the same

who can tell me …please thank

Hi

I am having the same problem. This is as far as I got in my attempt to use openframeworks on android.

Prior to this I installed xcode command line tools.

I have tried using ADT as well as downloading Eclipse and installing Android SDK and NDK myself. I get the same error each time.

Eclipse Console error message>>>
make: *** [all] Error 2
make: *** [Release] Error 2
make[1]: *** [Debug] Error 2
make[1]: *** [Release] Error 2
make[2]: *** […/…/…/libs/openFrameworksCompiled/lib/android/obj/armv5/Release/libs/openFrameworks/3d/of3dPrimitives.o] Error 127
make[2]: *** […/…/…/libs/openFrameworksCompiled/lib/android/obj/armv7/Debug/libs/openFrameworks/3d/of3dPrimitives.o] Error 127

Development Environment
OSX version 10.8.4
NDK r8d
SDK r22.2
ant 1.9.2
openFrameworks 0.8

Please advise

just to make sure, you _do have_ gcc installed? (I’m not a mac user, though)

I’m getting literally the exact same errors as SpencerIO and Eason

I’m on

OSX v. 10.9.1
NDK r8d
SDK 22.6.2
oF 0.8.1

Was there ever a solution found to this? I’m fairly certain I followed the steps exactly as they are written in the Android IDE setup guide. Actually I was able to get a few of the example apps to compile yesterday. Came back to my computer today after changing nothing and all the examples have the little x’s and the errors.

Thanks for the help!

Just an update, moving up to NDK r9b seemed to fix these errors for me.

Hii

Is there any update on this?

I tried both NDK r8d and NDK r9b but have similar problems.

I have deleted the whole thing and restarted with all the steps from scratch again and again to make sure i did not miss anything, but no luck yet.

Here’s my errors ( I only have imported one example, the androidAdvanced3dExample)

make: *** [Release] Error 2    androidAdvanced3DExample             C/C++ Problem
make[1]: *** [Release] Error 2    androidAdvanced3DExample             C/C++ Problem
make[2]: *** [../../../libs/openFrameworksCompiled/lib/android/obj/armv5/Release/libs/openFrameworks/3d/of3dPrimitives.o] Error 127    androidAdvanced3DExample             C/C++ Problem
make[2]: *** [../../../libs/openFrameworksCompiled/lib/android/obj/armv5/Release/libs/openFrameworks/3d/of3dUtils.o] Error 127    androidAdvanced3DExample             C/C++ Problem
make[2]: *** wait: No children.  Stop.    androidAdvanced3DExample             C/C++ Problem
make[2]: *** Waiting for unfinished jobs....    androidAdvanced3DExample             C/C++ Problem

Edit: It finally worked on my system with the 32 bit version of NDK 10.