openFrameworks android not compiling

Working though openFrameworks android page. After I import openFrameworks into eclipse I get an error with makefileCommon/config.shared.mk.

*** This package doesn't support your platform, probably you downloaded the wrong package?. Stop.

And in the emptyExample I get an error unable to make target.

*** No rule to make targetComputing/openFrameworks/libs/openFrameworksCompiled/project/makefileCommon/compile.project.mk’. Stop.`

Anyone have any ideas?

Thanks

check that you are compiling for android and not some other platform. there’s a step that explains how to use the dropdown in the hammer button to select the android build.

this is also explained now in the faq for common problems

I have set the ‘perspective’ to use the android SDK. In the android openFrameworks page it explains to change the openFrameworks project to android, under step I. (I think that’s what you were referring to. However I can only set android on openFrameworks master, not the project. After this I still get the same error.


mmh, no, while the project is selected in the toolbar there’s a button with a hammer icon, use the dropdown in that button to select android and then press it again to build

Ok, so I see the hammer when I change perspective to C++. That was my issue there. But android isn’t a default option. I can go into build configurations to manage and then I have tried to add a new one “openFrameworks > android”. selecting this and then building this with the hammer icon results in the same error.

I found much more success using the android studio method. http://openframeworks.cc/setup/android-studio/

I was able to get that working without an issue