opencv sample 0.06

hi,

when I run the opencvExample from of 0.06 I got the error:

OF_ERROR: ofUCUtils: Error opening device 0:

but my webcam works fine with guvcview (and others programs like amsn, etc). any idea about how to fix this example? how I can get more info about the error ? “error opening device 0” seems too much generic :expressionless:

Can you list details about your webcam? The more info the better.

Also, Arturo has a new GStreamer based video grabber here:
http://forum.openframeworks.cc/t/gstreamer-videograbber/2097/0

You might want to try that as well and see if it detects your camera.
Otherwise you should be able to run the opencv example by using the demo video instead of live video.

with OF006 gstreamer video grabber I got another error:

icelus bin # ./clickToLaunchApp_Debug.sh
/home/abner/of/oF006-Gstreamer/apps/examples/movieGrabberExample/bin
Probing devices with HAL…
Found device 0c45:63e0, getting capabilities…
Detected v4l2 device: Integrated Webcam
Driver: uvcvideo, version: 256
Capabilities: 0x04000001

./clickToLaunchApp_Debug.sh: line 5: 6100 Segmentation fault ./movieGrabberExample_debug

this my notebooks webcam, I’m using it only to test/learn OF. I dont know its specifications :confused:

can you try your camera with cheese and post if it works ok?

also can you debug the example in codeblocks and tell in what line does it crash?

arturo

my cam works with cheese too and the problem with OF video grabber was solved when I updated gstreamer here. it’s working now.

thanks.