ofxXMPP oF0.9 SSL conflict

Hello ofCommunity,
I am having troubles getting arturo’s ofxXMPP https://github.com/arturoc/ofxXMPP working.
I successfully recompiled libstrophe https://github.com/strophe/libstrophe and replaced the old 32bit version, but now I get duplicate symbol linking errors:

duplicate symbol _SHA1_Final in:
    /Users/thomasgeissl/programming/of/openFrameworks/addons/ofxXMPP/libs/strophe/lib/osx/strophe.a(libstrophe_la-sha1.o)
    ../../../libs/openssl/lib/osx/crypto.a(sha1dgst.o)
duplicate symbol _SHA1_Init in:
    /Users/thomasgeissl/programming/of/openFrameworks/addons/ofxXMPP/libs/strophe/lib/osx/strophe.a(libstrophe_la-sha1.o)
    ../../../libs/openssl/lib/osx/crypto.a(sha1dgst.o)
duplicate symbol _SHA1_Update in:
    /Users/thomasgeissl/programming/of/openFrameworks/addons/ofxXMPP/libs/strophe/lib/osx/strophe.a(libstrophe_la-sha1.o)
    ../../../libs/openssl/lib/osx/crypto.a(sha1dgst.o)

How would I solve this without having to modify the sources.
Is there a way to compile oF or libstrophe without openssl support?

Thomas