ofxXmlSettings library gone..?

https://github.com/openframeworks/openFrameworks/tree/master/addons/ofxXmlSettings/src seems to be the only one I can find of it, the main link from ofxaddons.com seems to be broken. would this be ok one to use since its a branch?

yes that’s the correct one. ofxxmlsettings has been folded into OF proper a long time ago. that repository you can see on ofxaddons was just a leftover from when this was still external to OF (3 years ago)

hmm. I must be doing something silly then…because I get errors in compiling an example project in ofxAnimatorVector:

clang: error: no such file or directory: ‘/Users/lukaszwieczorek/Documents/of_v0073_osx_release/addons/ofxAnimatorVector/…/…/…/addons/ofxXmlSettings/src/ofxXmlSettings.cpp’

doesn’t seem built in, unless I have to include a dir? I had to do something similar long time ago, but since have forgotten what that was.

yes it is built in, it comes with the OF release (in the addons folder), as an official addon. see e.g. here: https://github.com/openframeworks/openFrameworks/tree/master/addons/ofxXmlSettings

i think this is just a path error in ofxAnimatorVector… look at that path closer… going three levels up (3x …/) will put you outside the OF directory, so it’s looking one level too high.
taking a look at that project, the name is misleading, it’s not a proper addon, just an example, and it is supposed to reside one level deeper (e.g. /apps/myApps/ofxAnimatorVector), then it should work

hmm that doesn’t seem to work either. I had more luck using project generator, but now it just compiles and the app wont show up, doh. no errors or anything.

sorry this probably is no longer a bug post. It might have to be moved.

have you tried creating a new project with the PG (choosing ofxXmlSettings as an addon), compiling to see if that runs, and then just moving the source files (main, testapp.*, etc) over from ofxAnimatorVector?

hmm this produces a new error, yet stranger: Unknown type name ‘ofxXmlSettings’

in this file:

  
//  
//  VectorAnimator.h  
//  animatorVector  
//  
//  Created by Ben McChesney on 11/11/12.  
//  
//  
  
#ifndef animatorVector_VectorAnimator_h  
#define animatorVector_VectorAnimator_h  
  
#include "ofMain.h"  
  
#include "VectorFrame.h"  
  
class VectorAnimator  
{  
    public :  
        VectorAnimator( ) { }  
      
        void setup ( int _maxFrames , string xmlPath  = "" ) ;  
        void update ( ) ;  
        void draw ( ) ;  
          
  
        void addPoint ( ofPoint p ) ;  
        void clear( ) ;  
        void debugDraw( ) ;  
      
        vector<VectorFrame> frames ;  
        int currentFrame ;  
        int maxFrames ;  
      
        //Draw into FBO to still get nice trails  
        ofFbo fbo ;  
      
        //Xml Stuff  
        void saveToXml( string xmlPath ) ;  
        bool loadFromXml( string xmlPath ) ;  
        ofxXmlSettings xml ;  
      
        //Drag parameters  
        bool bDragging ;    //If the mouse is dragging show the frame before  
        void startDrag() ;  
        void endDrag() ;  
      
};  
  
#endif  

I also tried placing “myApps” on dir higher

also tried vector files in addons to be in src folder as well, same error.

[quote=“lukasz, post:7, topic:12058”]
hmm this produces a new error, yet stranger: Unknown type name ‘ofxXmlSettings’[/quote]
that doesn’t suprise me, you have removed the #include “ofxXmlSettings.h” line from that file. why?
https://github.com/benMcChesney/ofxAnimatorVector/blob/master/src/VectorAnimator.h