ofxVideoGrabberProsilica and ofXmlSettings conflict

Hi,

I’m working with a Prosilica cam through a giga ethernet interface on a Ubuntu Lucid bit 64 / OF 0.62 (same problem with OF 0.61).

I found stephanix’s ofxVideoGrabberProsilica which is working very well.
Now I try to add to my app an GUI with ofxSimpleGuiToo :

My app compile fine but when I run it I can’t grab any image from my cam.
ofxVideoGrabberProsilica say “failed to allocate capture buffer”

  
  
    unsigned long FrameSize = 0;  
    ret = PvAttrUint32Get( cameraHandle, "TotalBytesPerFrame", &FrameSize );  
    if( ret == ePvErrSuccess ){  
        // allocate the buffer for the single frame we need  
        cameraFrame.ImageBuffer = new char[FrameSize];  
        cameraFrame.ImageBufferSize = FrameSize;      
        ofLog(OF_LOG_VERBOSE, "camera asked for TotalBytesPerFrame");  
    } else {   
        ofLog(OF_LOG_ERROR, [color=#FF0080]"failed to allocate capture buffer")[/color];  
        return false;      
    }    
  

Later my app is unresponsive and I have to kill it.
After some investigations I find this clue :
The problem occur when ofXmlSettings is add as addons ( just in addons.make even if my app doesn’t include it ).

Is there a conflict betwen ofxVideoGrabberProsilica and ofXmlSettings OF addons or this is a more deeper problem beetwen tinyxml and PVApi libs ? I’ll try to find it myself but this is out of my knowledge.

Bye

i am seeing the same problem but have no idea how to fix this.

s.

so i also tried ofxcontrolpanel and got the same tinyxml malloc error.

then i came across this interface builder gui approach
http://forum.openframeworks.cc/t/interface-builder-amp;-of/2393/29

and it worked.
i just had to make sure to first init the videograbber and then do the NSApplicationMain stuff.

stephan.

Try the 1.26 version of the PvAPI SDK. It works for me.
http://www.alliedvisiontec.com/emea/products/software/windows/avt-pvapi-sdk.html