ofxUIslider error

Hello! im trying to run a code using ofxUI and some shader stuff and i get this error wich is weird i been using ofxUI in others projects and never saw this if someone knows whats going on let me know thanks!

what is the line of code in your app which is causing the error? are you sure you have included “ofxUI.h” in your header?

Hey! yes im sure.
here:

you have the arguments in the wrong order. on the first one, try:

gui->addWidgetDown(new ofxUISlider("var2", 0.0f, 10.0f, &var2, 160, 5));