ofxUI labels (font ?) problem on iOS

Hello,

I used ofxUI for some projects on the desktop (mac). No problems.

now i am digging into iOS where i am totally newbie !

I tried ofxUI examples ported to iOS and even a really simple stupid app i made (just one canvas and a label). Those are working except i can’t see any labels (label, buttons, sliders…)

I used to have similar problems on the desktop that was due to either :

  • button / canvas not large enough to embed the labels
  • no font to render (needed to copy /bin/data/GUI into the project)

I think this one seems related to font not being found ? I haven’t used ofxUI addon for some time, but was there no font to put into bin/data/GUI in previous versions ?

I tried to copy /bin/data/gui to the iOS device but still no luck (am i copying it to the right place ?)

I must be missing something because i can’t find any discussions related to similar issues on internet…

thanks for your help

Ok, this is a font problem : there used to be Helvetica.ttf in data/GUI/ directory in examples but not anymore

I don’t have any feedback from ofxUI developer but i guess it is probably due to copyrights

i just copied another font and it is ok now