ofxSyphon linking problems ...

Hi Everybody !

Well first of all i would like to congratulate the Syphon team for this amazing new tool which will allow a new brand of interconnections between several environments … congratulations and thanks for letting us play with it !!

So i’m under Openframeworks 0.62, in a MacBookPro with OSX 10.6.7, with XCode 3.2.4 (64bit) and i’m trying to integrate ofxSyphon in a small app, just for testing how is the integration of Syphon on the OF environemt …

What i did :

  • download the source’s from svn with this command line :
    svn checkout http://syphon-implementations.googlecode.com/svn/trunk/ syphon-implementations-read-only
  • setup a simple app with the Client code sniffed from SyphonExample project
  • drag & drop the ofxSyphon folder to my Xcode project …

It compiles fine but i’m facing some linking problems that go beyond my knowledge, sorry i’m quite new at Xcode …

I got 9 errors like this :

"_SyphonServerDescriptionUUIDKey", referenced from:  
_SyphonServerDescriptionUUIDKey$non_lazy_ptr in SyphonNameboundClient.o  
(maybe you meant: _SyphonServerDescriptionUUIDKey$non_lazy_ptr)  
"_SyphonServerDescriptionNameKey", referenced from:  
_SyphonServerDescriptionNameKey$non_lazy_ptr in SyphonNameboundClient.o  
(maybe you meant: _SyphonServerDescriptionNameKey$non_lazy_ptr)  
".objc_class_name_SyphonClient", referenced from:  
literal-pointer@__OBJC@__cls_refs@SyphonClient in SyphonNameboundClient.o  
"_SyphonServerDescriptionAppNameKey", referenced from:  
_SyphonServerDescriptionAppNameKey$non_lazy_ptr in SyphonNameboundClient.o  
(maybe you meant: _SyphonServerDescriptionAppNameKey$non_lazy_ptr)  
"_SyphonServerRetireNotification", referenced from:  
_SyphonServerRetireNotification$non_lazy_ptr in SyphonNameboundClient.o  
(maybe you meant: _SyphonServerRetireNotification$non_lazy_ptr)  
".objc_class_name_SyphonServerDirectory", referenced from:  
literal-pointer@__OBJC@__cls_refs@SyphonServerDirectory in  
"_SyphonServerUpdateNotification", referenced from:  
_SyphonServerUpdateNotification$non_lazy_ptr in SyphonNameboundClient.o  
(maybe you meant: _SyphonServerUpdateNotification$non_lazy_ptr)  
"_SyphonServerAnnounceNotification", referenced from  
_SyphonServerAnnounceNotification$non_lazy_ptr in SyphonNameboundClient.o  
(maybe you meant: _SyphonServerAnnounceNotification$non_lazy_ptr)  
ld: symbol(s) not found'  
I've checked that Syphon.framework is inside the ofxSyphon addon so i don't understand this linking problems ... any light into my darkness will be appreciated ...  
Thanks .  

Maybe you can combine with this post? http://forum.openframeworks.cc/t/issue-compiling-ofxsyphon-addon/6113/1

Might make it easier for people who have problems in the future to track them down.

Hi Joshua

I’ve linked the other post with this one, so people could find out possible solutions for their problems.
I’ve choosen to concentrate on this thread as this is more about adding ofxSyphon on an existing project rather then making ofxSyhpon examples to work.

So i’ll try to explain again more precisely all the things i made in order to let people know my steps …

  • after getting the sources from SVN with the command line :
svn checkout [http://syphon-implementations.googlecode.com/svn/trunk/](http://syphon-implementations.googlecode.com/svn/trunk/) syphon-implementations-read-only  

  • compile the Xcode project that comes in ofxSyphon found in SyphonImplementations/Openframeworks/
  • from this step i got the addon ofxSyphon folder build up and the SyphonExample build up (in /build folder)
  • i used this folders just created as sources from now on …
  • copy ofxShypon to /addons folder and SyphonExample to /apps/addonsExamples folder
  • to get the SyphonExample to work i had to change on “Project Settings” the [General][Base SDK] from Mac OSx 1.0 to Mac OSx 10.6 and everything worked.
  • at this point, the SyphonExample compiles and runs perfectly, you can check that everything is ok with this simple client and server apps : http://syphon.v002.info/downloads/Syphon%20Demo%20Apps.dmg

So now what i tried was to add ofxSyphon to one of my existing projects and here became another sort of compilation problems … more precisely a link error as i stated on my first post on this thread.
What i did is to drag&drop the ofxSyphon addon, and just paste the code from a client in my code … and link errors arise …

I’ve posted on the v002 forum, the creators of Syphon and there’s a thread here … not solved : http://forums.v002.info/topic.php?id=99

As everyone states, it’s a linking problem, so seems like the project can’t find the Syphon stuff … i’ve revised the linking stuff in Xcode but i can’t find the hole … I’ve uploaded both XCode projects the one from SyphonExample and the one from my app … I’m quite new at Xcode so there are things (many) about how to setup paths and libs that goes beyond my drag&drop knowledge … If any expert on Xcode settings could take a look … i’ll learn from it !

Syphon adds amazing possibilities to OF and exchange of stuff between apps so … go for it !

Thankx for it all …

Well keeping with this i got back to create an empty example with just the ofxSyphon stuff… and it worked with just a few tweaks.

I followed the steps stated on my previous post … then :

  • copied an “emptyExample”
  • open it with Xcode and then drag&drop the addon ofxSyphon to the project

If i compile with this i got this error at runtime :

GDB: Data Formatter temporarily unavailable, will re-try after a ‘continue’. (Cannot call into the loader at present, it is locked.)

So then what i need to do to make it work is :

-on Targets option in the main window of XCode groups and files …
-unfold the “emptyExample” tab and drag&drop the “Syphon.framework” present on the addon code folder (ofxSyphon/libs/Syphon/lib/osx/) into the CopyFiles tab, the same place where GLUT.framework is …

Now it works … I don’t know what i did, i just put that there because i saw it there on the SyphonExample from the Syphon svn … but i don’t quite understand why i need to do so … it’s the first time i need to make something like this to make an addon work … any expert could explain me what i did ?

Thanks … i hope it’s usefull info if someone gets stuck on a similar level …



i’ve just downloaded and i’m trying to build the Syphon project in


With no success.

Can anyone give some help?

Hi behem !

Well seems like it’s not finding Syphon framework …
Did u download the whole stuff from Syphon svn ?
I did it with this command on OSX terminal window :

svn checkout http://syphon-implementations.googlecode.com/svn/trunk/ syphon-implementations-read-only

This should download the different implementations and the framework …

My root folder structure is something like this …

Syphon Implementations read only/Syphon Framework
Syphon Implementations read only/Syphon Implementations

I guess that maybe you’re missing the /Syphon Framework ?
Maybe you could build up again the Syphon Framework with its Syphon.xcodeproj ?¿

Hope it helps …


Thanks e*,

i must have been really sleepy on Friday :slight_smile:

the framework is not at the svn three anymore, but i’ve managed to compile everything using the public available beta.


Thanks for your help.

Hello all,

It seems I am having issues trying to get ofxSyphon up and running. I’ve pored through the forums and my issues are similar to most people’s but I still can’t get it to work.

Here’s what I have done:

-checked out syphon from:
svn checkout http://syphon-implementations.googlecode.com/svn/trunk/ syphon-implementations-read-only

-compiled the xcode project in Syphon Implementations/OpenFrameworks/ofxSyphon.xcodeproj. Built successfully, however, I am not seeing the /build folder that some other people are seeing. Apparently the build folder contains the files I need to run the examples?

-After this, I copied the addon and the examples into the appropriate folders in oF 007.

-I opened the example, dragged the addon into the addons folder in xcode and try to compile. A bunch of errors. I know I am missing the syphon.framework file and the nameboundclient files.


hey barreled,

i had the same problem; might be some xcode-4-related path confusion…

after building, try right-clicking the ‘addons’ folder in your ‘Product’ group in the xcode sidebar and choose ‘show in finder’; that gave me the *actual* built ofxSyphon-addon folder (with the library included), as opposed to the ‘Components’ folder in ‘Syphon Implementations/OpenFrameworks/’ which I suspected to be the correct one.
these real builds were somewhere in /Developer/Xcode/DerivedData/ofxSyphon-[randomNameHere]/Build/Products/Debug
same for the ‘apps’ folder…

hope that helps !


after solving that, i got some errors that also appeared in this thread: http://forum.openframeworks.cc/t/ofxsyphon-errors/8657/9

solution was to drag the syphon framework to the ‘Copy Files’ build phase of the my projects’ target.


Worked for me too, thanks :slight_smile: